Closed Bug 1017560 Opened 5 years ago Closed 5 years ago

Choosing the same language will modify the state of Show Translation button

Categories

(Firefox :: Translation, defect)

32 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 33
Tracking Status
firefox32 --- verified
firefox33 --- verified

People

(Reporter: bogdan_maris, Assigned: florian)

References

Details

(Whiteboard: p=1 s=33.1 [qa!])

Attachments

(1 file)

Steps to reproduce:
1. Start Firefox.
2. Load https://www.mozilla.org/fr/contribute/.
3. Click 'Translate' on the Translate infobar.
4. Click Show Original.
5. In the first dropdown field/or the second, select again the same language as the one it already is.

Expected results: Show Translation button does not switch to Show Original.

Actual results: Show Translation button switches to Show Original.

Notes:
1. Reproducible on Windows, Linux and Mac OS X
2. Screencast showing the issue - https://db.tt/7Zfw68Ea
Flags: firefox-backlog+
Whiteboard: p=1 [qa+]
Attached patch PatchSplinter Review
This patch changes the code using _handleButtonHiding in the infobar to make it less fragile (it will now use the state saved in the TranslationUI object, rather than having hard coded parameter values after some operations).
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #8437667 - Flags: review?(felipc)
Attachment #8437667 - Flags: review?(felipc) → review+
Marco, please add this to the current iteration.
Flags: needinfo?(mmucci)
Added to Iteration 33.1
Flags: needinfo?(mmucci)
Whiteboard: p=1 [qa+] → p=1 s=33.1 [qa+]
https://hg.mozilla.org/mozilla-central/rev/652092f2085d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Verified as fixed using latest Nightly on Windows 7 64bit, Ubuntu 14.04 32bit, Ubuntu 13.04 64bit and Mac OS X 10.9.2.
Status: RESOLVED → VERIFIED
Whiteboard: p=1 s=33.1 [qa+] → p=1 s=33.1 [qa!]
Comment on attachment 8437667 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This bug is part of the automatic translation feature, which we want to A/B test with a subset of Aurora 32 users.
User impact if declined: Infobar can be in a wrong state if the user chooses the same language in the language dropdowns
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): minimal
String or IDL/UUID changes made by this patch: none
Attachment #8437667 - Flags: approval-mozilla-aurora?
Attachment #8437667 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on Windows 7 64bit, Ubuntu 14.04 32bit and Mac OS X 10.9.3 using latest Aurora.
You need to log in before you can comment on or make changes to this bug.