2.38% win7 tsvgx regression on may 28th (fx32) on fxteam from push a0586a5ec2da

RESOLVED WONTFIX

Status

()

Core
Layout
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: jmaher, Assigned: mstange)

Tracking

({perf, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_regression])

(Reporter)

Description

4 years ago
this is probably the same bug as bug 1017256, filing as separate as the platform is different and the test is as well.

here is a graph of the failure:
http://graphs.mozilla.org/graph.html#tests=[[281,131,25]]&sel=1401190795000,1401363595000&displayrange=7&datatype=running

I did some retriggers to help reduce and mistakes due to noise:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&fromchange=d94346125453&tochange=e368bba6dbbc&jobname=Windows%207%2032-bit%20mozilla-inbound%20talos%20svgr

we go from 246-248 -> 255-260 when the 3 patches landed.
(Assignee)

Updated

4 years ago
Summary: 2.38% win7 tvgx regression on may 28th (fx32) on fxteam from push a0586a5ec2da → 2.38% win7 tsvgx regression on may 28th (fx32) on fxteam from push a0586a5ec2da
(Assignee)

Comment 1

4 years ago
Unfortunately this is a different regression (with a different cause) than bug 1017256.
And bug 1016437 does not affect Windows, so this must have been caused by bug 1009679.
Assignee: nobody → mstange
No longer blocks: 1016437
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
And the regression is that layerizing the scroll indicator slowed down pageload + firstpaint of these four pages:
https://hg.mozilla.org/build/talos/raw-file/tip/talos/page_load_test/svgx/composite-scale.svg
https://hg.mozilla.org/build/talos/raw-file/tip/talos/page_load_test/svgx/composite-scale-opacity.svg
https://hg.mozilla.org/build/talos/raw-file/tip/talos/page_load_test/svgx/composite-scale-rotate.svg
https://hg.mozilla.org/build/talos/raw-file/tip/talos/page_load_test/svgx/composite-scale-rotate-opacity.svg

Avi, do we have on-Talos profiling support for these tests? How can I use it?
(Reporter)

Comment 3

3 years ago
when we uplifted to aurora, we seem to have a net win:
http://graphs.mozilla.org/graph.html#tests=[[281,131,25],[281,52,25]]&sel=1397237120718,1405013120718&displayrange=90&datatype=running
No longer blocks: 1004427
(Reporter)

Comment 4

3 years ago
We are approaching 3 months on this with no action, fx32 has shipped, Any concerns with closing this bug as wontfix?
(Reporter)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.