removed accesskeys should be come back

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: teramako, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

Bug 1000513 removes accesskeys.
Why?
(Reporter)

Updated

4 years ago
Depends on: 1000513
OS: Mac OS X → All
Hardware: x86 → All
The accesskeys were removed because once the patch for bug 1000513 landed, the accesskeys would be undiscoverable and behave unexpectedly for people who didn't know about them and were trying to use the accesskey to reach a different menuitem that may have shared one of the accesskeys.

It is unconventional to support hidden accesskeys. All of the menuitems that had their accesskeys removed also have keyboard shortcuts:

Alt+LeftArrow for Back (I assume Alt+RightArrow for Back when in RTL)
Alt+RightArrow for Forward (I assume Alt+LeftArrow for Forward when in RTL)
F5 for Refresh (also, Ctrl+R)
Ctrl+D for Bookmark This Page
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #1)
> The accesskeys were removed because once the patch for bug 1000513 landed,
> the accesskeys would be undiscoverable and behave unexpectedly for people
> who didn't know about them and were trying to use the accesskey to reach a
> different menuitem that may have shared one of the accesskeys.
> 
> It is unconventional to support hidden accesskeys. All of the menuitems that
> had their accesskeys removed also have keyboard shortcuts:
> 
> Alt+LeftArrow for Back (I assume Alt+RightArrow for Back when in RTL)
> Alt+RightArrow for Forward (I assume Alt+LeftArrow for Forward when in RTL)
> F5 for Refresh (also, Ctrl+R)
> Ctrl+D for Bookmark This Page


By your theory, I feel we don't have to have these navigation context menu in the context menu. If they are invoked by global shortcut keys, should we have item in context menu? It's just same with or without navigation icons in context menu, isn't it?
I think that is an exaggeration of my above statements. The context menuitems are useful and we don't want to completely get rid of them. In fact, by making them iconic hopefully more users will see them and find them useful.

The question of keyboard shortcuts vs access keys deals with users who are using the context menu through their keyboard. For those users, there are already keyboard shortcuts for these menuitems.

However, we lack contextual shortcuts for mouse-only users, and that is why these context menuitems are still relevant.

Comment 4

4 years ago
So what you're saying is to make a few menus easier to read, you completely destroyed functionality that has been part of the browser for more than a decade?  How does that make sense to anyone?
You need to log in before you can comment on or make changes to this bug.