3.24% Win7 CanvasMark regression on fx-team on May 28th from push d2596e506798

RESOLVED WONTFIX

Status

()

Firefox
Theme
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

({perf, regression})

Trunk
x86
Windows Phone 7
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_regression])

(Reporter)

Description

4 years ago
CanvasMark has regressed:
http://graphs.mozilla.org/graph.html#tests=[[297,132,25]]&sel=1401221472000,1401394272000&displayrange=7&datatype=running

I did some retriggers, this is a smaller regression that appears to be Win7 only:
https://tbpl.mozilla.org/?tree=Fx-Team&fromchange=c086224d0d64&tochange=62b743e5a4f9&jobname=Windows%207%2032-bit%20fx-team%20talos%20chromez

Looking at the two patches, I suspect it is bug 1016942, I could be wrong.
No longer blocks: 1016942
(Reporter)

Comment 1

4 years ago
:bkerensa, is there a reason for removing this as depending on bug 1016942 since that appears to have caused the regression?  That is the workflow we do for all talos regression bugs.
Flags: needinfo?(bkerensa)
(In reply to Joel Maher (:jmaher) from comment #1)
> :bkerensa, is there a reason for removing this as depending on bug 1016942
> since that appears to have caused the regression?  That is the workflow we
> do for all talos regression bugs.

Sorry about that not sure why Bugzilla did that I was working on 1016942 but did not get any collision nag.
Depends on: 1016942
Flags: needinfo?(bkerensa)
(Reporter)

Comment 3

4 years ago
no worries
I don't see how bug 1016942 could have caused this.
Blocks: 1016942
No longer depends on: 1016942
(Reporter)

Comment 5

4 years ago
:dao, there is also https://hg.mozilla.org/integration/fx-team/rev/d2596e506798 (bug 1016834) which doesn't seem related.  Also the push before didn't run this test, but that is mobile only changes.  I do know that the the retriggers seem to show a solid break between 5300-5400 (before) and 5200-5300 (with this push and after).  The drop is seem and any noise is accounted for.
(Reporter)

Comment 6

4 years ago
this appears on windows8 as well as a 2.58% regression:
http://graphs.mozilla.org/graph.html#tests=[[297,63,31]]&sel=1401279716000,1401452516000&displayrange=7&datatype=running
(Reporter)

Comment 7

4 years ago
overall this is a win on Aurora- the original regression still shows a regression (despite some small wins back) on non pgo on fx-team:
http://graphs.mozilla.org/graph.html#tests=[[297,132,25],[297,52,25]]&sel=1397237004071,1405013004071&displayrange=90&datatype=running

going to untrack from blocking firefox32
No longer blocks: 1004427
(Reporter)

Comment 8

3 years ago
as we have an overall win here, I don't see a need to fix this regression since it was cancelled out.  Please reopen if you feel the need to work on this more.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.