Closed Bug 1017757 Opened 8 years ago Closed 8 years ago

Crash in JSCompartment::wrapId() while stability testing

Categories

(Core :: JavaScript Engine, defect)

30 Branch
ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 964537

People

(Reporter: ggrisco, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [caf priority: p1][CR 671130][b2g-crash])

Crash Data

Attachments

(1 file)

Ran multimedia test scripts overnight and found crash with signature:

[@ ? | JSCompartment::wrapId(JSContext*, jsid*) ]

No further STR available.  This particular crash signature has been seen twice so far.  Wondering if it is at all related to bug 1016512 or bug 1017740.
Keywords: crash
Whiteboard: [b2g-crash]
Whiteboard: [b2g-crash] → [CR 671130][b2g-crash]
Crash observed on: 

Device: msm8610
Gonk Version: AU_LINUX_GECKO_B2G_KK_3.5.01.04.00.113.105
Moz BuildID: 20140518000201
B2G Version: 1.4
Gecko Version: 30.0
Gaia:  http://git.mozilla.org/?p=releases/gaia.git;a=commit;h=7019efdbcfa58d3ff4702b018420db3d8753bb93
Gecko: http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=46b48309fc782275104e128f58a601123c21922e
Whiteboard: [CR 671130][b2g-crash] → [caf priority: p1][CR 671130][b2g-crash]
Crash observed on: 

Device: msm8610
Gonk Version: AU_LINUX_GECKO_B2G_KK_3.5.01.04.00.113.122
Moz BuildID: 20140604000202
B2G Version: 1.4
Gecko Version: 30.0
Gaia:  http://git.mozilla.org/?p=releases/gaia.git;a=commit;h=0c16adced7c51f795ef250aebe184f60b6a9b987
Gecko: http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=157a45f1fa280296dc9204de6def0b5b370ed2bd
This stack is not actionable at all, we are not even sure if JSCompartment::wrapId() is indeed on the stack at the moment of the crash.
Crash observed on: 

Device: msm8610
Gonk Version: AU_LINUX_GECKO_B2G_KK_3.5.01.04.00.113.124
Moz BuildID: 20140607000201
B2G Version: 1.4
Gecko Version: 30.0
Gaia:  http://git.mozilla.org/?p=releases/gaia.git;a=commit;h=0c3321207bfad3d6ee936f3ee8d87e5d075e6ca9
Gecko: http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=1dd8365f64f3131bc20e44172b54a81e9c9572ce
(In reply to cafbot (PoC: ggrisco) from comment #2)
> Crash observed on: 
> 
> Device: msm8610
> Gonk Version: AU_LINUX_GECKO_B2G_KK_3.5.01.04.00.113.122
> Moz BuildID: 20140604000202
> B2G Version: 1.4
> Gecko Version: 30.0
> Gaia: 
> http://git.mozilla.org/?p=releases/gaia.git;a=commit;
> h=0c16adced7c51f795ef250aebe184f60b6a9b987

Crash on this build was observed without any call or sms made.
> Gecko:
> http://git.mozilla.org/?p=releases/gecko.git;a=commit;
> h=157a45f1fa280296dc9204de6def0b5b370ed2bd
Greg/:nbp , can we add more debugging to get better crash info or better diagnostics?
(In reply to bhavana bajaj [:bajaj] from comment #6)
> Greg/:nbp , can we add more debugging to get better crash info or better
> diagnostics?

I am attaching patches on Bug 1016512, as currently we are unable to distinguish these bugs.
Crash observed on: 

Device: msm8610
Gonk Version: AU_LINUX_GECKO_B2G_KK_3.5.01.04.00.113.130
Moz BuildID: 20140614000202
B2G Version: 1.4
Gecko Version: 30.0
Gaia:  http://git.mozilla.org/?p=releases/gaia.git;a=commit;h=164644d91290708a71436dfdf4301e33b92e2c77
Gecko: http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=89e926ba3a65372a74d72c30a8773081820cccbb
Taking in 1.4 as JS errors caused angst to stability
blocking-b2g: 1.4? → 1.4+
With the fix from bug 964537, this issue does not reproduce. Marking this as a duplicate.
Status: NEW → RESOLVED
blocking-b2g: 1.4+ → ---
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 964537
You need to log in before you can comment on or make changes to this bug.