Closed Bug 1017858 Opened 7 years ago Closed 7 years ago

[B2G][Settings][Legal Information] 'Open Source Notices' page will never load

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S3 (6june)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- fixed

People

(Reporter: dharris, Assigned: gasolin)

References

()

Details

(Keywords: regression, Whiteboard: [2.0-flame-test-run-1][p=1])

Attachments

(2 files)

Attached file Flame 2.0 Logcat
Description:
When the user attempts to open the 'Open Source Notices' page from legal information, a blank white screen is shown and the page with information will never load

Repro Steps:
1) Update a Flame to BuildID: 20140527040202
2) Open Settings App
3) Scroll down to the bottom> Tap on Device Information
4) Tap on Legal Information> Open Source Notices

Actual:
This page will never load and will just display white

Expected:
A page with information about Open Source Notices will load on the screen

2.0 Environmental Variables:
Device: Flame 2.0
BuildID: 20140527040202
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: cbe4f69c2e9c
Version: 32.0a1
Firmware Version: v10G-2

Keywords: Blank, Nothing, Performance

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/6112/
See attached: Logcat, Video - https://www.youtube.com/watch?v=xx6YfNUv6nk&edit=vd
This issue DOES occur on Buri 2.0


Buri 2.0

2.0 Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140529040201
Gaia: 4142df90c71abdc1e3a87cd37dff1a22d5e38b34
Gecko: 1e712b724d17
Version: 32.0a1
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0



This issue DOES occur on Open C 2.0

Open_C 2.0

2.0 Environmental Variables:
Device: Open_C 2.0
BuildID: 20140529040201
Gaia: 4142df90c71abdc1e3a87cd37dff1a22d5e38b34
Gecko: 1e712b724d17
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL


This issue does NOT occur on Flame 1.4

Flame 1.4

1.4F Environmental Variables:
Device: Flame 1.4F
BuildID: 20140529000204
Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
Gecko: 2181cac4d0fc
Version: 30.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


This issue does NOT occur on Buri 1.4

Buri 1.4

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140529000204
Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
Gecko: 2181cac4d0fc
Version: 30.0
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


This issue does NOT occur on Open C 1.4


1.4 Environmental Variables:
Device: OPENC 1.4
BuildID: 20140529000204
Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
Gecko: 2181cac4d0fc
Version: 30.0
Firmware Version: US-Ebay P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
blocking-b2g: --- → 2.0?
QA Contact: jharvey
B2G Inbound Regression Window

Last Working
Environmental Variables:
Device: Buri
BuildID: 20140324015215
Gaia: b4e45644fe928b41f1807a9050710645b28ea5cb
Gecko: 326611aea79f
Version: 31.0a1
Firmware Version: v1.2-device.cfg

First Broken
Environmental Variables:
Device: Buri
BuildID: 20140324021715
Gaia: 7324a7b921b7b60de1427124e0efcafa91f4be75
Gecko: 4e523b67e349
Version: 31.0a1
Firmware Version: v1.2-device.cfg

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: b4e45644fe928b41f1807a9050710645b28ea5cb
Gecko: 4e523b67e349

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 7324a7b921b7b60de1427124e0efcafa91f4be75
Gecko: 326611aea79f

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/b4e45644fe928b41f1807a9050710645b28ea5cb...7324a7b921b7b60de1427124e0efcafa91f4be75
Broken by bug 964180.

Arthur - Can you investigate?
Blocks: 964180
Flags: needinfo?(arthur.chen)
Assignee: nobody → arthur.chen
Flags: needinfo?(arthur.chen)
Seems the data src is wrong, quick fix
Attachment #8433840 - Flags: review?(arthur.chen)
Comment on attachment 8433840 [details] [review]
pull request redirect to github

data-src was used to workaround bug 825622. As I am not able to reproduce anymore, let's also remove the related code in settings.js (grep 825622).
Attachment #8433840 - Flags: review?(arthur.chen)
Comment on attachment 8433840 [details] [review]
pull request redirect to github

get rid of work around. please kindly review it again, thanks
Attachment #8433840 - Flags: review?(arthur.chen)
Assignee: arthur.chen → gasolin
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1][p=1]
Target Milestone: --- → 2.0 S3 (6june)
Comment on attachment 8433840 [details] [review]
pull request redirect to github

r=me with the comment addressed, thanks.
Attachment #8433840 - Flags: review?(arthur.chen) → review+
blocking-b2g: 2.0? → 2.0+
master: 5b58a6ac2394970cfc3feadaabd4db8f20d369f5
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.