TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_auto-pretty-print-02.js | A promise chain failed to handle a rejection at chrome://browser/content/devtools/debugger-panes.js:477 - A promise chain faile

RESOLVED DUPLICATE of bug 1013945

Status

RESOLVED DUPLICATE of bug 1013945
4 years ago
4 months ago

People

(Reporter: Yoric, Unassigned)

Tracking

(Blocks: 1 bug)

29 Branch

Firefox Tracking Flags

(Not tracked)

Details

Once bug 1016387 lands, this will become an orange.

03:33:25  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_auto-pretty-print-02.js | A promise chain failed to handle a rejection at chrome://browser/content/devtools/debugger-panes.js:477 - A promise chain failed to handle a rejection: TypeError: gThreadClient is null
03:33:25     INFO -  Stack trace:
03:33:25     INFO -      SourcesView.prototype<.togglePrettyPrint<@chrome://browser/content/devtools/debugger-panes.js:477:11
03:33:25     INFO -  TaskImpl_run@resource://gre/modules/Task.jsm:282:13
03:33:25     INFO -  TaskImpl@resource://gre/modules/Task.jsm:247:3
03:33:25     INFO -  createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:224:7
03:33:25     INFO -  SourcesView.prototype<._onSourceSelect<@chrome://browser/content/devtools/debugger-panes.js:828:9
03:33:25     INFO -  TaskImpl_run@resource://gre/modules/Task.jsm:282:13
03:33:25     INFO -  Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
03:33:25     INFO -  this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

also

03:33:25  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_auto-pretty-print-02.js | A promise chain failed to handle a rejection at chrome://browser/content/devtools/debugger-view.js:316 - A promise chain failed to handle a rejection: TypeError: gThreadClient is null
03:33:25     INFO -  Stack trace:
03:33:25     INFO -      DebuggerView.maybeShowBlackBoxMessage@chrome://browser/content/devtools/debugger-view.js:316:1
03:33:25     INFO -  SourcesView.prototype<._onSourceSelect<@chrome://browser/content/devtools/debugger-panes.js:836:5
03:33:25     INFO -  TaskImpl_run@resource://gre/modules/Task.jsm:282:13
03:33:25     INFO -  Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
03:33:25     INFO -  this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7
03:33:39  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_blackboxing-05.js | A promise chain failed to handle a rejection at chrome://browser/content/devtools/debugger-panes.js:439 - A promise chain failed to handle a rejection: TypeError: gThreadClient is null
03:33:39     INFO -  Stack trace:
03:33:39     INFO -      SourcesView.prototype<.updateToolbarButtonsState@chrome://browser/content/devtools/debugger-panes.js:439:11
03:33:39     INFO -  SourcesView.prototype<._onStopBlackBoxing<@chrome://browser/content/devtools/debugger-panes.js:852:5
03:33:39     INFO -  TaskImpl_run@resource://gre/modules/Task.jsm:282:13
03:33:39     INFO -  resolve@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/deprecated-sync-thenables.js:40:11
03:33:39     INFO -  then@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/deprecated-sync-thenables.js:20:43
03:33:39     INFO -  resolve@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/deprecated-sync-thenables.js:72:11
03:33:39     INFO -  SourceScripts.prototype.setBlackBoxing/<@chrome://browser/content/devtools/debugger-controller.js:1265:36
03:33:39     INFO -  DebuggerClient.requester/</<@resource://gre/modules/devtools/dbg-client.jsm:348:9
03:33:39     INFO -  makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:84:7
03:33:39     INFO -  emit@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/event/core.js:96:9
03:33:39     INFO -  Request.prototype.emit@resource://gre/modules/devtools/dbg-client.jsm:1028:29
03:33:39     INFO -  DebuggerClient.prototype.onPacket/<@resource://gre/modules/devtools/dbg-client.jsm:901:9
03:33:39     INFO -  resolve@resource://gre/modules/devtools/deprecated-sync-thenables.js:40:11
03:33:39     INFO -  then@resource://gre/modules/devtools/deprecated-sync-thenables.js:20:43
03:33:39     INFO -  then@resource://gre/modules/devtools/deprecated-sync-thenables.js:58:9
03:33:39     INFO -  DebuggerClient.prototype.onPacket@resource://gre/modules/devtools/dbg-client.jsm:905:1
03:33:39     INFO -  LocalDebuggerTransport.prototype.send/<@resource://gre/modules/devtools/dbg-client.jsm -> resource://gre/modules/devtools/transport/transport.js:540:11
03:33:39     INFO -  makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:84:7
Also 3:37:11  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_pretty-print-10.js | A promise chain failed to handle a rejection at chrome://browser/content/devtools/debugger-panes.js:439 - A promise chain failed to handle a rejection: TypeError: gThreadClient is null
03:37:11     INFO -  Stack trace:
03:37:11     INFO -      SourcesView.prototype<.updateToolbarButtonsState@chrome://browser/content/devtools/debugger-panes.js:439:11
03:37:11     INFO -  SourcesView.prototype<.toggleBlackBoxing<@chrome://browser/content/devtools/debugger-panes.js:524:5
03:37:11     INFO -  TaskImpl_run@resource://gre/modules/Task.jsm:282:13
03:37:11     INFO -  resolve@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/deprecated-sync-thenables.js:40:11
03:37:11     INFO -  then@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/deprecated-sync-thenables.js:20:43
03:37:11     INFO -  resolve@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/deprecated-sync-thenables.js:72:11
03:37:11     INFO -  SourceScripts.prototype.setBlackBoxing/<@chrome://browser/content/devtools/debugger-controller.js:1265:36
03:37:11     INFO -  DebuggerClient.requester/</<@resource://gre/modules/devtools/dbg-client.jsm:348:9
03:37:11     INFO -  makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:84:7
03:37:11     INFO -  emit@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/event/core.js:96:9
03:37:11     INFO -  Request.prototype.emit@resource://gre/modules/devtools/dbg-client.jsm:1028:29
03:37:11     INFO -  DebuggerClient.prototype.onPacket/<@resource://gre/modules/devtools/dbg-client.jsm:901:9
03:37:11     INFO -  resolve@resource://gre/modules/devtools/deprecated-sync-thenables.js:40:11
03:37:11     INFO -  then@resource://gre/modules/devtools/deprecated-sync-thenables.js:20:43
03:37:11     INFO -  then@resource://gre/modules/devtools/deprecated-sync-thenables.js:58:9
03:37:11     INFO -  DebuggerClient.prototype.onPacket@resource://gre/modules/devtools/dbg-client.jsm:905:1
03:37:11     INFO -  LocalDebuggerTransport.prototype.send/<@resource://gre/modules/devtools/dbg-client.jsm -> resource://gre/modules/devtools/transport/transport.js:540:11
03:37:11     INFO -  makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:84:7
Component: Developer Tools → Developer Tools: Debugger
I fixed these in bug 1013945.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1013945

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.