If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Multi-line paste in URL bar now inserts spaces in place of newlines

RESOLVED DUPLICATE of bug 1014246

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 1014246
3 years ago
3 years ago

People

(Reporter: bayern, Unassigned)

Tracking

29 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

Insert a multi-line buffer into the URL bar


Actual results:

Spaces replace newlines in the buffer, making the URL invalid


Expected results:

Newlines should simply be eliminated when pasting text into the URL bar, as occurred in prior versions of Firefox.

The major use-case in support of this behavior is an attempt to copy and paste a URL from a program like PuTTY, or other terminal emulator, from text that has wrapped in the terminal.  If the newlines are eliminated, the URL can load without further editing.  If spaces are inserted, which is never the right behavior because properly formed URLs should have spaces, then the URL must be edited manually.

I note a recent bug report (321000) requesting opposite behavior in the "search bar." Replacing newlines with spaces may well be appropriate there, but the URL bar has a different role, and different behavior is appropriate for it.

Comment 1

3 years ago
I reproduced in Fx29, but not reproduce in Fx30, fixed?
Component: Untriaged → Location Bar

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1014246
You need to log in before you can comment on or make changes to this bug.