Closed Bug 1018263 Opened 6 years ago Closed 6 years ago

Selected column in selection list properties does not work

Categories

(SeaMonkey :: Composer, defect)

defect
Not set

Tracking

(seamonkey2.26 wontfix, seamonkey2.27 wontfix, seamonkey2.28 fixed, seamonkey2.29 fixed, seamonkey2.30 fixed)

RESOLVED FIXED
seamonkey2.30
Tracking Status
seamonkey2.26 --- wontfix
seamonkey2.27 --- wontfix
seamonkey2.28 --- fixed
seamonkey2.29 --- fixed
seamonkey2.30 --- fixed

People

(Reporter: neil, Assigned: neil)

Details

Attachments

(1 file, 1 obsolete file)

In the selection list properties dialog (available through the debug QA extension, or by accessing the properties of an existing selection list) the column that displays which option is selected does not display anything.

This is a regression from bug 407956 which wasn't picked up at the time.
Attached patch Proposed patch (obsolete) — Splinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8431634 - Flags: review?(philip.chee)
Sat Jun 07 2014 00:49:41
Error: treeBoxObject.getPrimaryColumn is not a function
Source file: chrome://editor/content/EdSelectProps.js
Line: 683
Comment on attachment 8431634 [details] [diff] [review]
Proposed patch

r=me

(In reply to Philip Chee from comment #2)
> Sat Jun 07 2014 00:49:41
> Error: treeBoxObject.getPrimaryColumn is not a function
> Source file: chrome://editor/content/EdSelectProps.js
> Line: 683
I'm not sure how this dialog ever worked?
Attachment #8431634 - Flags: review?(philip.chee) → review+
(In reply to Philip Chee from comment #2)
> Error: treeBoxObject.getPrimaryColumn is not a function
> Source file: chrome://editor/content/EdSelectProps.js
> Line: 683

Whoa, that's a regression introduced by bug 221619... fix coming up.
Attachment #8431634 - Attachment is obsolete: true
Attachment #8436012 - Flags: review?(philip.chee)
Comment on attachment 8436012 [details] [diff] [review]
With added columns

r=me thanks!
Attachment #8436012 - Flags: review?(philip.chee) → review+
Pushed comm-central changeset 699551e9deae.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.30
Comment on attachment 8436012 [details] [diff] [review]
With added columns

[Approval Request Comment]
Regression caused by (bug #): 407956
User impact if declined: Reduced dialog functionality
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Low, dialog rarely used
String changes made by this patch: None
Attachment #8436012 - Flags: approval-comm-beta?
Attachment #8436012 - Flags: approval-comm-aurora?
Comment on attachment 8436012 [details] [diff] [review]
With added columns

a=me
Attachment #8436012 - Flags: approval-comm-beta?
Attachment #8436012 - Flags: approval-comm-beta+
Attachment #8436012 - Flags: approval-comm-aurora?
Attachment #8436012 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.