Closed Bug 1018457 Opened 5 years ago Closed 2 years ago

[B2G][Marketplace] 'Open Browser' in Wikipedia app transition to the thumbnail page instead of the directed browser page

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3T affected, b2g-v1.4 affected, b2g-v2.0 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3T --- affected
b2g-v1.4 --- affected
b2g-v2.0 --- affected

People

(Reporter: psiphantong, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [tarako-exploratory])

Attachments

(1 file)

Attached file t3.txt
Description:
When the user tap on Open Browser in Wikipedia app, the browser transition to the thumbnail page instead of the directed browser page

Repro Steps:
1) Update a Tarako to BuildID: 20140530014002
2) No Browser app open 
3) Download Wikipedia app from the Marketplace
4) Open Wikipedia app > tap open browser icon 
5) Tap Open in Browser

Actual:
'Open in Browser' transition to the thumbnail page instead of the directed browser page

Expected:
'Open in Browser' should not have a transition 


1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140530014002
Gaia: e68858693b71d917c9c5ee7e215f7ceea04635f7
Gecko: 1945abae19ff
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29


This issue occurs on the Flame v2.0

Environmental Variables:
Device: Flame v2.0 
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: v10G-2


This issue only occurs on the Flame 1.4F, when the user launches the app from the marketplace because the bottom bar does not exist when launching the app from homescreen

1.4F Environmental Variables:
Device: Flame 1.4F
BuildID: 20140529000204
Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
Gecko: 2181cac4d0fc
Version: 30.0
Firmware Version: v10F-3

Repro frequency: 100%
See attached: video clip, logcat, https://www.youtube.com/watch?v=uRpCEkPa2iY
qawanted for base
This is likely an app issue, but 1.3 testing will confirm this.
Component: Panning and Zooming → Preinstalled B2G Apps
Product: Core → Tech Evangelism
blocking-b2g: --- → backlog
This issue does NOT reproduce on Flame 1.3 base.

Environmental Variables:
Device: Flame 1.3
BuildID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko: Unknown
Version: 28.0
Firmware Version: v10G-2
Keywords: qawanted
Component: Preinstalled B2G Apps → Gaia::Browser
Product: Tech Evangelism → Firefox OS
So doing some debugging here - what I'm seeing is that the Wikipedia app is trying to call window.open here to open up the Wikipedia site on the web (e.g. https://en.m.wikipedia.org/wiki/Main_Page). This results in opening the browser app, but not the target URL in question here.

The root cause here isn't something limited to Wikipedia as well - this is probable use case that could happen with multiple apps that intending to open web content in a window, so a bunch of web apps can easily be affected by this problem. This is also a regression.

Given the above analysis, I think we need this fixed on Tarako & 1.4.
blocking-b2g: backlog → 1.3T?
Whiteboard: [tarako-exploratory] → [tarako-exploratory][1.4-approval-needed]
(In reply to psiphantong from comment #0)
> 
> This issue only occurs on the Flame 1.4F, when the user launches the app
> from the marketplace because the bottom bar does not exist when launching
> the app from homescreen

That sounds like a different bug. Can you open a separate bug for this?
Flags: needinfo?(psiphantong)
Double checked, this issue does occur on the 1.4 flame 

1.4F Environmental Variables:
Device: Flame 1.4F
BuildID: 20140529000204
Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
Gecko: 2181cac4d0fc
Version: 30.0
Firmware Version: v10F-3
Flags: needinfo?(psiphantong)
QA Contact: lmauritson
(In reply to psiphantong from comment #6)
> Double checked, this issue does occur on the 1.4 flame 
> 
> 1.4F Environmental Variables:
> Device: Flame 1.4F
> BuildID: 20140529000204
> Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
> Gecko: 2181cac4d0fc
> Version: 30.0
> Firmware Version: v10F-3

That isn't the question I asked here. I asked for a different bug to get filed here for the other issue seen here.
Flags: needinfo?(psiphantong)
(In reply to Jason Smith [:jsmith] from comment #7)
> (In reply to psiphantong from comment #6)
> > Double checked, this issue does occur on the 1.4 flame 
> > 
> > 1.4F Environmental Variables:
> > Device: Flame 1.4F
> > BuildID: 20140529000204
> > Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
> > Gecko: 2181cac4d0fc
> > Version: 30.0
> > Firmware Version: v10F-3
> 
> That isn't the question I asked here. I asked for a different bug to get
> filed here for the other issue seen here.
 
I understand there should be a separated bug, but when I checked on the device(1.4f) that I noted on, the bottom bar does exist so I believed I made a mistake on that.  If I reproduce the bottom bar bug again, I will write it up.
Flags: needinfo?(psiphantong)
To clarify, the thumbnail page only appears for a moment before transitioning to the correct page. The video cut off before showing that the desired page is actually loaded in the end.

This goes back as far as I can test on both Tarako and Flame.

Environmental Variables:

Device: Tarako 
Build ID: 20140402094402
Gaia: 578fdccea89a88b417d296f8cf20b39099d44be4
Gecko: 34ed4cbc5a59
Version: 28.1  
Firmware Version: SP6821a-Gonk-4.0-5-12
User Agent: Mozilla/5.0 (Mobile;rv:28:0) Gecko/28.0 Firefox/28.0

Device: Flame 
Build ID: 20140417000006
Gaia: 7591e9dc782ac2e97d63a96f9deb71c7b3588328
Gecko: e71ed4135461
Version: 31.0a1  
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:31.0) Gecko/31.0 Firefox/31.0
Then try doing the window on Buri.
Actually wait a second - comment 9 is indicating that the video is misleading here. Can we get an updated video here that shows the full depth of the problem here (aka don't cut it off at the transition - show the problem, then wait a few seconds).
blocking-b2g: 1.3T? → ---
Whiteboard: [tarako-exploratory][1.4-approval-needed] → [tarako-exploratory]
QA Contact: lmauritson → dgomez
Attaching updated video.
http://youtu.be/gP3GY3oPSlI
Keywords: qawanted
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.