Closed Bug 1018579 Opened 10 years ago Closed 10 years ago

Some VP8 WebM videos can not be played

Categories

(Core :: Audio/Video, defect)

29 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: mossroy, Unassigned)

References

Details

Attachments

(1 file)

Attached video P5270914-trusty.webm
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140428193813

Steps to reproduce:

Open the attached WebM video file with Firefox


Actual results:

The video does not play at all : the cursor seems to jump at the end.
Seeking anywhere inside the video does not help.
This same file can be played without issues on Chromium, VLC and Totem (on Ubuntu)

See original bug report on Ubuntu : https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1323822


Expected results:

Either the file is "corrupted" in the sense that it does not comply to the expected format. In this case, I would expect to have an error message somewhere.
Either it is correct, and it should be played by Firefox.
Here is the mkvinfo of the attached file :

$ mkvinfo P5270914-trusty.webm
+ EBML head
|+ EBML version: 1
|+ EBML read version: 1
|+ EBML maximum ID length: 4
|+ EBML maximum size length: 8
|+ Doc type: webm
|+ Doc type version: 2
|+ Doc type read version: 2
+ Segment, size 217051
|+ Seek head (subentries will be skipped)
|+ EbmlVoid (size: 163)
|+ Segment information
| + Timecode scale: 1000000
| + Muxing application: Lavf54.20.4
| + Writing application: Lavf54.20.4
| + Segment UID: 0x3e 0x93 0xba 0x8b 0xfd 0xdf 0xd6 0xff 0xd9 0x02 0xc0 0xaa 0xbd 0x1a 0x95 0xd2
| + Duration: 4.772s (00:00:04.772)
|+ Segment tracks
| + A track
| + Track number: 1 (track ID for mkvmerge & mkvextract: 0)
| + Track UID: 1
| + Lacing flag: 0
| + Language: eng
| + Codec ID: V_VP8
| + Track type: video
| + Default duration: 0.033ms (30000.300 frames/fields per second for a video track)
| + Video track
| + Pixel width: 1920
| + Pixel height: 1080
| + Display width: 1920
| + Display height: 1080
| + Display unit: 3 (aspect ratio)
| + A track
| + Track number: 2 (track ID for mkvmerge & mkvextract: 1)
| + Track UID: 2
| + Lacing flag: 0
| + Language: eng
| + Codec ID: A_VORBIS
| + Track type: audio
| + Audio track
| + Channels: 2
| + Sampling frequency: 48000
| + Bit depth: 32
| + CodecPrivate, length 3949
|+ Cluster

Please notice that the "default duration" value seems strange to me
Please note that this video has been generated with libav 9.13-0ubuntu0.14.04.1 on Ubuntu Trusty, by converting from a H.264 source video. It can be reproduced very easily with other source videos.
When converting with some other versions of libav (at least the one of Ubuntu Precise), or the latest version of ffmpeg, the generated video file can be played by Firefox.
See the details on Launchpad issue.

So it looks like a "misunderstanding" between this libav version and Firefox.
Maybe there is an issue in libav itself.
I created this issue on Buzilla because the video works on several other implementations, and because the issue is the same with Firefox on W7 (not ubuntu-specific)
Reproduced in 32.0a1 (2014-06-01), win 7 x64.
Works in Chrome.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
I have same problem with my MP4 encoded on Ubuntu 14.04 :
http://ikilote.net/Galeries/Autres/Divers/test_20140627.mp4
http://ikilote.net/Galeries/Autres/Divers/test_20140627.webm

(Webm works in Chrome, but MP4 works without sound, all are unplayable in Firefox)
It looks like it's related to a libav bug. See https://bugzilla.libav.org/show_bug.cgi?id=597 and https://bugzilla.libav.org/show_bug.cgi?id=341
It has been fixed in libav between versions 9.13 and 9.14.

So it looks like Firefox is less permissive than Gstreamer, Chromium and VLC on WebM files...

In any case, could Firefox output an error message in such cases, instead of silently failing?
I close this bug as invalid.
I still believe Firefox should improve the user feedback in such cases, but it was a bug in libav, not in Firefox
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: