Can't add RSS feed with Cyrillic URL -> support idn urls for feeds

RESOLVED FIXED in Thunderbird 33.0

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: alex3kov, Assigned: alta88)

Tracking

Thunderbird 33.0
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140514164129

Steps to reproduce:

Tried to subscribe to http://партиявеликоеотечество.рф/feed/
It works fine in Firefox Live Bookmarks.


Actual results:

Received error "The Feed URL could not be found."


Expected results:

Successfully subscribing to a feed.
(Assignee)

Comment 1

5 years ago
Posted patch idn.patch (obsolete) — Splinter Review
Value has been deprecated for ValueUTF8 for nsIRDFResource for a long time, and it finally matters with idn urls.
Assignee: nobody → alta88
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #8432274 - Flags: review?(mkmelin+mozilla)
(Assignee)

Updated

5 years ago
Assignee: alta88 → nobody
Component: Untriaged → Feed Reader
OS: Linux → All
Product: Thunderbird → MailNews Core
Hardware: x86_64 → All
Summary: Can't add RSS feed with Cyrillic URL → Can't add RSS feed with Cyrillic URL -> support idn urls for feeds
(Assignee)

Updated

5 years ago
Assignee: nobody → alta88
It seems this fixes the subscription, but every message (view as webpage) can't connect as encoding seems messed up.
Tested http://партиявеликоеотечество.рф/za-stalingrad

"www.партиявеликоеотечество.рф could not be found. Please check the name and try again."
(Assignee)

Comment 3

5 years ago
Posted patch idn.patchSplinter Review
this fixes the url for web pages, but it seems like MsgHdrToMimeMessage should do this sort of thing generically.
Attachment #8432274 - Attachment is obsolete: true
Attachment #8432274 - Flags: review?(mkmelin+mozilla)
Attachment #8439925 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8439925 [details] [diff] [review]
idn.patch

Review of attachment 8439925 [details] [diff] [review]:
-----------------------------------------------------------------

Works fine now, thx! r=mkmelin
Attachment #8439925 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/57bcf6cc9e8a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 33.0

Comment 8

4 years ago
Comment on attachment 8625281 [details]
screenshot - causing false charset with German umlauts

This new feature causes problems rendering German umlauts in de dc:creator field, see attachement. The charset of the sender's address seems to be wrong.
Thanks for help on this matter.

Comment 9

4 years ago
I am seeing a similar thing whit the feed from the Danish newspaper Dagbladet Børsen. The character ø is displayed with a ?.
http://borsen.dk/services/newsfeed/rss/
I don't think this bug fix was implemented the right way, so I reopen it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

4 years ago
bug 1023285.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.