[OSX] PDF viewer zoom issues when using Cmd + mouse control

RESOLVED FIXED in Firefox 40

Status

()

defect
P3
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: FlorinMezei, Assigned: browtayl)

Tracking

Trunk
Firefox 40
All
macOS
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog -

Firefox Tracking Flags

(firefox38 affected)

Details

(Whiteboard: [pdfjs-c-ux][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/5926)

Reproducible on:
Firefox 30 beta 9 - 20140529161749
 Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0
Latest Firefox 31 Aurora - 20140602004003 
 Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0
Latest Firefox 32 Nightly - 20140602030202
 Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0

Steps to reproduce:
1. Open a PDF (e.g. https://enregistrement.grandlyon.fr/Enregistrement/CG/CG.pdf).
2. Zoom in/out using Ctrl + mouse scroll -> the document properly zooms in/out while the PDF viewer control toolbar remains at a fixed size (same as when using the toolbar +/- zoom controls).
3. Zoom in/out using Cmd + mouse scroll.

Expected results:
The document properly zooms in/out, same as when using Ctrl + mouse scroll.

Actual results:
PDF viewer control toolbar zooms in together with the document itself.

Notes: 
1. Cmd + keyboard "+"/"-" zooms in/out same as Ctrl + keyboard "+"/"-". Cmd should behave just like Ctrl in this case, and zoom the document instead of the whole page.
2. Reproduces on Firefox 20.0 (when Cmd + mouse scroll was introduced for zoom control) so it's not a regression.
Reporter

Updated

5 years ago
Summary: PDF viewer zoom issues when using Cmd + mouse control → [Mac OS] PDF viewer zoom issues when using Cmd + mouse control
Reporter

Updated

5 years ago
Version: 30 Branch → Trunk
Reporter

Updated

5 years ago
Summary: [Mac OS] PDF viewer zoom issues when using Cmd + mouse control → [OSX] PDF viewer zoom issues when using Cmd + mouse control
Priority: -- → P3
Whiteboard: [pdfjs-c-ux]
Flags: firefox-backlog?
I missed that this is not a regression, therefore no need to set status flags for this one.
Not adding to the Firefox team backlog since this is unlikely something that will be fixed by someone on the Firefox team.
Flags: firefox-backlog? → firefox-backlog-
Assignee

Comment 3

4 years ago
I have created a [pull request](https://github.com/mozilla/pdf.js/pull/5926) to fix this issue.
Assignee: nobody → browtayl
Whiteboard: [pdfjs-c-ux] → [pdfjs-c-ux][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/5926
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Depends on: 1157827
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Depends on: 1170063
Reporter

Updated

4 years ago
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.