[B2G][Cost Control]Black screen is displayed when attempting to launch cost control app

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Cost Control
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Ross Kuhlman (rkuhlman@qanalydocs.com), Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 affected)

Details

Attachments

(1 attachment)

Created attachment 8432752 [details]
UsageAppLog.txt

The cost control app does not launch. User just sees a blankscreen when attempting to launch app.

Repro Steps:
1) Update a Flame to BuildID: 20140602072051
2) Launch Cost Control app

Actual:
Black screen is displayed, app is non-interactable

Expected:
Cost Control app launches

Master M-C Environmental Variables:
Device: Flame Master M-C
BuildID: 20140602072051
Gaia: 82679a5ce84d1b6bf388da6536d5682a3ad56de3
Gecko: 6a984e21c2ca
Version: 32.0a1
Firmware Version: v10G-2

Notes:
Repro frequency: 100%
See attached: logcat
Issue does not occur on v1.4

assigning jmitchell as QA Contact
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
Keywords: qaurgent, regression, regressionwindow-wanted, smoketest
QA Contact: jmitchell

Updated

4 years ago
blocking-b2g: --- → 2.0?
QA Contact: jmitchell → jmercado
User Agent: Mozilla/5.0 (Mobile; rv:32.0)Gecko/32.0 Firefox/32.0
B2g inbound Flame regression Window

Last working Environmental Variables:
Device: Flame
BuildID: 20140601233002
Gaia: 82679a5ce84d1b6bf388da6536d5682a3ad56de3
Gecko: 793cc4452672
Version: 32.0a1


First Broken Environmental Variables:
Device: Flame
BuildID: 20140602023002
Gaia: e57a57bf88ac30afd15965b1d9b42a2212ed11fe
Gecko: c03a85df8615
Version: 32.0a1


Last working gaia / First broken gecko - Does not occur
Gaia: 82679a5ce84d1b6bf388da6536d5682a3ad56de3
Gecko: c03a85df8615


First broken gaia / Last working gecko - Issue occurs - indicates a Gaia issue
Gaia: e57a57bf88ac30afd15965b1d9b42a2212ed11fe
Gecko: 793cc4452672


https://github.com/mozilla-b2g/gaia/compare/82679a5ce84d1b6bf388da6536d5682a3ad56de3...e57a57bf88ac30afd15965b1d9b42a2212ed11fe
Keywords: qaurgent, regressionwindow-wanted
Are we absolutely sure the window above is correct? The push log doesn't really have a strong candidate for causing this issue.
Keywords: qaurgent, regressionwindow-wanted

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
QA Contact: jmercado → ddixon
Using the latest trunk build on the Flame, this works for me - I can see the Cost Control app using:

Gaia   61cd07a8b5fa017777db6d345e00afb4fb8789b7
SourceStamp f28005b84ed0
BuildID 20140603040210
Version 32.0a1
Base 10G
Resolving this as WFM since it is not able to reproduced using the latest build.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: qaurgent, regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.