A vague bug about tab not closing by middle-click of mouse until you do a right-click

RESOLVED DUPLICATE of bug 1067470

Status

()

Core
Widget: Win32
RESOLVED DUPLICATE of bug 1067470
4 years ago
3 years ago

People

(Reporter: Mayank Bansal, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140602072051

Steps to reproduce:

I have been noticing this since about a month ago.  Intermittent STR:

1. Open a few tab.
2. Middle click on a tab to close it


Actual results:

The tab does not close until I do a right-click anywhere : inside the Nightly window or outside it. 
While the tab is in this semi-dead state, the "X" button on the tab does not get highlighted when i mouse over it.


Expected results:

tab should close when i do a middle click.

Comment 1

3 years ago
I may have stumbled upon a variant of this with Aurora 33:

Firefox sometimes freezes for a few seconds when deleting a tab with mouse middle-click to the tab title. Tab does not disappear and also changing tab is impossible, Firefox is frozen. After a few seconds Firefox wakes and finally deletes the tab. But it also performs other mouse actions as if the deletion would have been done immediately: e.g. if I have re-clicked the tab trying to delete it again, Firefox actually also deletes the next tab (like it would have been on the place of the deleted tab when I made the second click). It almost sounds like Firefox pauses the screen updates, but performs the actions in background.

This has happened a few times in the last 1-2 weeks, not very often, but every now and then.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140831004002 CSet: e9b04954e337

Windows 7 x64, Nvidia display card.
(Reporter)

Comment 2

3 years ago
This is almost certainly a dupe of bug 1065463 . Since that bug is seeing more action, duping to it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1065463
Duplicate of bug: 1067470
You need to log in before you can comment on or make changes to this bug.