[B2G][Tarako][Facebook] Check-in using geolocation is not functioning

RESOLVED WONTFIX

Status

Tech Evangelism
Preinstalled B2G Apps
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: rpribble, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3T affected)

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8433518 [details]
Screenshot.png

Description:
Check-in using geolocation to automatically find user's location will not always function correctly. User is able to search manually for locations, butwill see an error message for geolocation. Geolocation is enabled and 'share' is tapped when prompted to give Facebook permissions.

Repro Steps:
1) Update device to BuildID: 20140602014001
2) Enable geolocation
3) Install and launch Facebook from the marketplace 
4) Tap 'share' when prompted by pop-up to allow Facebook to know your location
5) Tap check-in

Actual:
Geolocation to locate user automatically is not functioning.

Expected:
Geolocation finds user's position automatically.

Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140602014001
Gaia: 335486c42498fa7a93c21e4d6121199728602ab8
Gecko: 55e4d83019e5
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29

Notes: When I encountered this issue, I uninstalled the Facebook app and reinstalled and it seemed to fix the issue on that try.

Repro frequency: 100%
See attached: Screenshot
(Reporter)

Comment 1

4 years ago
Qwanted for results on Buri v1.3 or will post in the morning.
Keywords: qawanted
Created attachment 8434311 [details]
geolocation_logcat.txt

Geolocation permission is asked, having said that, the geolocation icon doesn't appear in the status bar.

After turning on the geolocation in the settings, and granting access the status icon appears and facebook does give a list of locations.
The issue also occurs in v1.3 if geolocation is turned off.
Gaia      2408c2238254776b0d3716753b7bf917883c9915
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/560138f48a17
BuildID   20140603024001
Version   28.0
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Buri


I think it might be by design that if geolocation is turned off, then other apps won't get the location.
status-b2g-v1.3: --- → affected
Keywords: qawanted
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #3)
> The issue also occurs in v1.3 if geolocation is turned off.
> Gaia      2408c2238254776b0d3716753b7bf917883c9915
> Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/560138f48a17
> BuildID   20140603024001
> Version   28.0
> ro.build.version.incremental=324
> ro.build.date=Thu Dec 19 14:04:55 CST 2013
> Buri
> 
> 
> I think it might be by design that if geolocation is turned off, then other
> apps won't get the location.

That's expected behavior since geolocation is turned off. The bug here is talking about the case when geolocation is turned on.
status-b2g-v1.3: affected → ---
Keywords: qawanted
This issue DOES repro on Buri 1.3

Environmental Variables:
Device: Buri 1.3
Build ID: 20140603024001
Gaia: 2408c2238254776b0d3716753b7bf917883c9915
Gecko: 560138f48a17
Version: 28.0 (1.3) 
Firmware Version: v1.2device.cfg
Keywords: qawanted

Updated

4 years ago
Component: General → Preinstalled B2G Apps
Product: Firefox OS → Tech Evangelism

Comment 6

3 years ago
The Tarako device does not have GPS.  Closing this bug, as this performance is expected.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Updated

3 years ago
Resolution: INVALID → WONTFIX

Updated

3 years ago
Blocks: 869192
You need to log in before you can comment on or make changes to this bug.