Gaia closed - failing persona test, and grey builds

RESOLVED FIXED in 2.0 S3 (6june)

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kgrandon, Assigned: jedp)

Tracking

({regression})

unspecified
2.0 S3 (6june)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 fixed)

Details

Two issues seen lately: 

1 - Failing test: test_persona_app.py test_persona_app.TestPersonaStandard.test_persona_standard_sign_in

2 - grey builds, git checkout -qf 00e8f0be07efd77344c1e37c6494db0622ebfd05

fatal: reference is not a tree: 00e8f0be07efd77344c1e37c6494db0622ebfd05

The command "git checkout -qf 00e8f0be07efd77344c1e37c6494db0622ebfd05" failed and exited with 128 during .



Persona error log: 

TEST-START test_persona_app.py

test_persona_standard_sign_in (test_persona_app.TestPersonaStandard) ... ERROR

======================================================================

ERROR: None

----------------------------------------------------------------------

Traceback (most recent call last):

File "/home/travis/build/mozilla-b2g/gaia/travis_venv/local/lib/python2.7/site-packages/marionette_client-0.7.7-py2.7.egg/marionette/marionette_test.py", line 163, in run

testMethod()

File "/home/travis/build/mozilla-b2g/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/persona/test_persona_app.py", line 34, in test_persona_standard_sign_in

moz_id.switch_to_frame()

File "/home/travis/build/mozilla-b2g/gaia/tests/python/gaia-ui-tests/gaiatest/apps/ui_tests/regions/persona.py", line 29, in switch_to_frame

self.wait_for_ready_event()

File "/home/travis/build/mozilla-b2g/gaia/tests/python/gaia-ui-tests/gaiatest/apps/ui_tests/regions/persona.py", line 48, in wait_for_ready_event

self.wait_for_element_present(*self._app_ready_event)

File "/home/travis/build/mozilla-b2g/gaia/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 29, in wait_for_element_present

lambda m: m.find_element(by, locator))

File "/home/travis/build/mozilla-b2g/gaia/travis_venv/local/lib/python2.7/site-packages/marionette_client-0.7.7-py2.7.egg/marionette/wait.py", line 143, in until

cause=last_exc)

TimeoutException: Traceback (most recent call last):

File "/home/travis/build/mozilla-b2g/gaia/travis_venv/local/lib/python2.7/site-packages/marionette_client-0.7.7-py2.7.egg/marionette/wait.py", line 122, in until

rv = condition(self.marionette)

File "/home/travis/build/mozilla-b2g/gaia/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 29, in <lambda>

lambda m: m.find_element(by, locator))

File "/home/travis/build/mozilla-b2g/gaia/travis_venv/local/lib/python2.7/site-packages/marionette_client-0.7.7-py2.7.egg/marionette/marionette.py", line 1204, in find_element

response = self._send_message('findElement', 'value', **kwargs)

File "/home/travis/build/mozilla-b2g/gaia/travis_venv/local/lib/python2.7/site-packages/marionette_client-0.7.7-py2.7.egg/marionette/decorators.py", line 35, in _

return func(*args, **kwargs)

File "/home/travis/build/mozilla-b2g/gaia/travis_venv/local/lib/python2.7/site-packages/marionette_client-0.7.7-py2.7.egg/marionette/marionette.py", line 624, in _send_message

self._handle_error(response)

File "/home/travis/build/mozilla-b2g/gaia/travis_venv/local/lib/python2.7/site-packages/marionette_client-0.7.7-py2.7.egg/marionette/marionette.py", line 655, in _handle_error

raise NoSuchElementException(message=message, status=status, stacktrace=stacktrace)

TimeoutException: Timed out after 10.2 seconds, caused by <class 'marionette.errors.NoSuchElementException'>

TEST-UNEXPECTED-FAIL | test_persona_app.py test_persona_app.TestPersonaStandard.test_persona_standard_sign_in |

----------------------------------------------------------------------

Ran 1 test in 29.340s
Looking at Travis, it appears the builds started failing about 4 hours ago.

This doesn't correlate with any Persona-related server changes.
The builds also started failing before the other tree closure.
Not to derail the Gaia portion of this, but Web QA's tests using Persona as a sign-in method are failing too, across the board, which might give us a clue; for those, they've started around 11:57 PDT (though we don't run every minute, so the window might be a bit earlier).
I believe bug 1011084 is the culprit.  The provisioning api needs to be exposed!
Just pushed a backout of bug 1011084 to b-i. Will merge it to m-c ASAP in time for the next scheduled nightlies.
blocking-b2g: --- → 2.0?
(In reply to Stephen Donner [:stephend] from comment #4)
> Not to derail the Gaia portion of this, but Web QA's tests using Persona as
> a sign-in method are failing too, across the board, which might give us a
> clue; for those, they've started around 11:57 PDT (though we don't run every
> minute, so the window might be a bit earlier).

FYI, spun this off as bug 1019852.
blocking-b2g: 2.0? → 2.0+
Keywords: regression
Backout merged to m-c.

https://hg.mozilla.org/mozilla-central/rev/2b6b0ced08ef
Assignee: nobody → jparsons
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S3 (6june)
I should have a patch by the end of the day to fix this.
Sorry, commented on the wrong bug.  That was intended for the bug I suspect to be the cause of this issue, bug 1011084.
Is the problem solved for everyone?  I'm still having Persona sign-in problems on the UI Test app when using a primary (e.g., mozilla.org) IdP.  I also found the same problem with a two-week old image on my Flame, and these tests weren't failing two weeks ago.  Hrm.
Flags: needinfo?(kgrandon)
I'm seeing CSP horrors in my logcat:

E/GeckoConsole(28966): [JavaScript Warning: "Content Security Policy: The page's settings blocked the loading of a resource: An attempt to execute inline scripts has been blocked" {file: "https://login.mozilla.org/provision" line: 0 column: 0 source: "onsubmit attribute on DIV element"}]
E/GeckoConsole(28966): [JavaScript Warning: "Content Security Policy: The page's settings blocked the loading of a resource: An attempt to execute inline scripts has been blocked" {file: "https://login.mozilla.org/provision" line: 0 column: 0 source: "onchange attribute on DIV element"}]
E/GeckoConsole(28966): [JavaScript Warning: "Content Security Policy: The page's settings blocked the loading of a resource: An attempt to execute inline scripts has been blocked" {file: "https://login.mozilla.org/provision" line: 0 column: 0 source: "onsubmit attribute on DIV element"}]
E/GeckoConsole(28966): [JavaScript Warning: "Content Security Policy: The page's settings blocked the loading of a resource: An attempt to execute inline scripts has been blocked" {file: "https://login.mozilla.org/provision" line: 0 column: 0 source: "onchange attribute on DIV element"}]
Looks like someone restarted the latest build. If it finished green in ~10 mins or so I'm fine to reopen the tree. I don't have much context about the persona UI test app though, but we should do that in another bug if this turns green.
Flags: needinfo?(kgrandon)
Kevin, thanks.

I think we still have an issue with "primary" identities.  That is, identities that are backed by a provider that actually implements the browserid protocol.  mozilla.com is a primary, which would explain why I'm not able to sign in as me @mozilla.com, while the tests continue to be green, because they use personatestuser.org to provision new identities directly from persona.org, which is not a primary identity provider.

I'll open a separate bug to dig into primary identity provisioning.
I've opened Bug 1020020 to track the provisioning problem.
Duplicate of this bug: 1020299
You need to log in before you can comment on or make changes to this bug.