Closed Bug 1019832 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Facebook] Burmese is appearing as blocks

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: rpribble, Unassigned)

Details

(Whiteboard: [tarako-exploratory])

Attachments

(1 file)

Attached image Screenshot.png
Description:
Burmese characters are displaying as blocks.

Repro Steps:
1) Update device to BuildID: 20140602014001
2) Install and launch Facebook from the marketplace
3) View a user's profile or a friend suggestion that appears in Burmese

Actual:
Burmese characters appear as blocks.

Expected:
No language is displayed as blocks.

Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140602014001
Gaia: 335486c42498fa7a93c21e4d6121199728602ab8
Gecko: 55e4d83019e5
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29

Notes: 

Repro frequency: 100%
See attached: Screenshot
Naoki - Isn't this expected since we don't have multi-locale support on Tarako builds right now?
Flags: needinfo?(nhirata.bugzilla)
I think the block character is a separate issue from the locale.

Japanese call it mojibake ( http://en.wikipedia.org/wiki/Mojibake ).  I believe that it has to do with character encoding or the character not being in populated in the font ( see bug 828299 as an example of the later )

I am not sure if we are not handling it correctly or if facebook is not handling it correctly.
blocking-b2g: --- → 1.3T?
Flags: needinfo?(nhirata.bugzilla)
Qwanted for results on Buri v1.3 or will post in the morning.
Keywords: qawanted
This issue does not repro on the Buri 1.3 MOZ ril.

Environmental Variables:
Device: Buri v1.3 MOZ ril
BuildID: 20140529024024
Gaia: 5bd226b03a2d63dfe9df204f7c0afb9984e8fd42
Gecko: 42ef074f380f
Version: 28.0
Firmware Version: v1.2-device.cfg

Burmese language appears correctly.
NI? James as a fyi.

Michael, is there a good way to find out which side the issue is on for the font?
Flags: needinfo?(mwu)
Flags: needinfo?(james.zhang)
I don't think this qualifies as mojibake. Mojibake is when there's issues with character encoding. We're merely missing fonts here. On Tarako, the fonts are configured per target region, so if the build doesn't have the Burmese locale, it probably doesn't have support for Burmese text either.
Flags: needinfo?(mwu)
http://en.wikipedia.org/wiki/Help:Multilingual_support_%28Burmese%29

It seems like we need the font to support the script based on what mwu stated.
I guess this is invalid in a sense that we aren't targetting Burmese?
Flags: needinfo?(james.zhang)
some fonts are removed to save image size. same with Chinese
since Burmese is not targeted, let's close as won't fix
Status: NEW → RESOLVED
blocking-b2g: 1.3T? → ---
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.