If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

useragent per-site settings Tool

VERIFIED DUPLICATE of bug 80658

Status

()

Core
Preferences: Backend
--
enhancement
VERIFIED DUPLICATE of bug 80658
16 years ago
15 years ago

People

(Reporter: CJ Kucera, Assigned: Brian Nesse (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I'd really like to be able to define what my Useragent string is on a per-site
basis, similar to what is implemented for per-site javascript turnoff.  So the
syntax in the prefs.js or user.js would be something like:

user_pref("useragent.NS4win98.sites", "http://www.beatnik.com http://www.blah.com");
user_pref("useragent.NS4win98", "Mozilla/4.7 [en] (Win98; U)");

That way I've got a "class" defined called "NS4win98" and I can arbitrarily
assign sites to that class.  There would still be the "general" useragent that's
overrideable with "general.useragent.override" which is the default, and what
plugins would see when getting registered, etc.  I don't particularly care if
there's a UI on top of it at all . . .

If this were implemented properly, it would probably take care of bug 83376.

This could possibly collide with bug 46029, although I suppose 46029 would only
be dealing with the "general.useragent.override" setting.

Comment 1

16 years ago
By "properly" you mean that the Useragent sent to the web server would be
different than that seen by Java. Yes that would solve bug 83376 but I believe
that actually separating the two (the only way of solving 83376) is a necessary
first step to implement useragent per-site setting, which is a much bigger task.
This means that bug 83376 is actually a proxy for "Separate the useragent used
by http from the real one seen by plug-ins".

This is while confirming this bug I mark it as dependant on bug 83376. If we
create a new useragent separation bug, the depandance should be moved.
Status: UNCONFIRMED → NEW
Depends on: 83376
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
Okay, I've created bug 102042 to look into the "splitting" problem like you
suggested.  (I used your wording for the summary; hope that's okay.)

While this one does seem a bit daunting, I'm willing to look into bug 102042,
though I don't actually have any experience with coding Mozilla, so if someone
with more experience than I is interested, you'd be able to code it much faster
than I could.
Depends on: 102042
No longer depends on: 83376
(Assignee)

Comment 3

16 years ago
Trying to change the preferences back end to support multiple entries for a
preference would be essentially a total re-write.

There is a preference out there "network.proxy.no_proxies_on" which is used in
the manner you suggest. The code which uses it saves the list out as one long
string preference and parses it when it is loaded. You might consider a solution
like this.

mtoltz and I have also talked about this general principle a couple of times as
he has also expressed an interest in per site preferences for security. Adding
him to the cc list because I know he has given this some thought.
No longer depends on: 102042
Summary: useragent per-site settings → Toolbar prefs not remembered
(Assignee)

Comment 4

16 years ago
Replacing fields that bugzilla removed/changed with my last comment.
Depends on: 102042
Summary: Toolbar prefs not remembered → useragent per-site settings Tool

Comment 5

16 years ago
Believe this is what bug 80658 talks about doing, marking as a dup.

*** This bug has been marked as a duplicate of 80658 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: useragent per-site settings Tool → useragent per-site settings Tool
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.