If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G] [Messaging] Large recipient lists will not scroll when swiped

RESOLVED DUPLICATE of bug 1003820

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 1003820
3 years ago
3 years ago

People

(Reporter: CKreinbring, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 affected)

Details

(Whiteboard: [2.0-flame-test-run-1], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8433634 [details]
Log of large recipient list scroll attempt

Description:
If the list of recipients is large enough that the whole list is not visible when it is expanded, the list will not scroll when the user swipes up and down.

Repro Steps:
1) Update Flame to Build ID: 20140530040207
2) Have at least 15 different contacts with phone numbers.
3) Launch the Messages app and tap the New Message icon.
4) In the To field, tap the + icon and select a contact.  Repeat until there are at least 10 contacts in the To field.
5) Make sure the cursor is in the To field (keyboard is visible) and swipe the To field down to show the entire list of recipients.
6) Observe the list while attempting to swipe the To field up and down.

Actual:
The list of recipients does not scroll when attempting to swipe it up and down.

Expected:
The list of recipients scrolls up and down when the user swipes up and down.

Environmental Variables
Device: Flame 2.0
Build ID: 20140530040207
Gecko: https://hg.mozilla.org/mozilla-central/rev/e6f113c83095
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Platform Version: 32.0a1
Firmware Version: V10g-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?filter-id=7967
See attached video clip and logcat log
(Reporter)

Comment 1

3 years ago
Able to repro on Open C 2.0 but unable to repro on Flame 1.4.  The recipient list is able to scroll with no errors on the Flame 1.4.  Attempts to repro on Buri 2.0 failed due to the fact that the recipient list would not expand when swiped.  A bug will be written for that issue shortly.

Open C 2.0
Build ID: 20140530040207
Gecko: https://hg.mozilla.org/mozilla-central/rev/e6f113c83095
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Platform Version: 32.0a1
Firmware Version: P821A10v1.0.0806_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4
Build ID: 20140530000202
Gecko: https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/25011f9a8f26
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Platform Version: 30.0
Firmware Version: V10g-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
status-b2g-v1.4: --- → unaffected
Keywords: regression, regressionwindow-wanted
(Reporter)

Updated

3 years ago
(Reporter)

Comment 2

3 years ago
After another attempt, I was able to repro the bug on Buri 2.0 mozilla RIL

Build ID: 20140529040201
Gecko: https://hg.mozilla.org/mozilla-central/rev/1e712b724d17
Gaia: 4142df90c71abdc1e3a87cd37dff1a22d5e38b34
Platform Version: 32.0a1
Firmware Version: V1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Updated

3 years ago
blocking-b2g: --- → 2.0?
Yep, already have bug 1003820 for this (already 2.0+)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1003820
Clearing QA-Wanted flags as this bug has been resolved
Keywords: regressionwindow-wanted

Updated

3 years ago
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.