about:newtab should lazily build its search panel popup

RESOLVED FIXED in Firefox 33

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: adw, Assigned: adw)

Tracking

Trunk
Firefox 33
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=2 s=33.1 [qa-])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Right now, about:newtab populates its search panel popup as soon as it receives the current search state from ContentSearch.jsm.  Instead, it should populate the panel when the panel is opened.

This may help fix some of the TART regression in bug 1004429, although I wasn't able to prove it using similar patches on tryserver and the various talos tools.  It trades work done on visibility change (when the page moves out of the preloader) for work done when you open the panel, but I think that's actually a good trade-off since it's less likely to regress TART, the amount of work is small and unlikely to cause a noticable delay when you open the panel, and if you never open the panel -- and right now, it's hard to open the panel because many providers don't have logos -- you don't pay for the work.
Flags: firefox-backlog+

Updated

4 years ago
Whiteboard: p=2 → p=2 [qa-]

Updated

4 years ago
Assignee: nobody → adw
Status: NEW → ASSIGNED
Whiteboard: p=2 [qa-] → p=2 s=33.1 [qa-]
(Assignee)

Comment 1

4 years ago
Created attachment 8440248 [details] [diff] [review]
patch

This builds on patch 2 in bug 1019989.

https://tbpl.mozilla.org/?tree=Try&rev=fb32d078180d
Attachment #8440248 - Flags: review?(ttaubert)
Comment on attachment 8440248 [details] [diff] [review]
patch

Review of attachment 8440248 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #8440248 - Flags: review?(ttaubert) → review+
https://hg.mozilla.org/mozilla-central/rev/79f665a0e949
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
You need to log in before you can comment on or make changes to this bug.