unable to open pdf attachments in gmail.com mobile interface

RESOLVED DUPLICATE of bug 1036987

Status

RESOLVED DUPLICATE of bug 1036987
4 years ago
4 years ago

People

(Reporter: praveen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Mobile; OPENC; rv:28.0) Gecko/28.0 Firefox/28.0 (Nightly/Aurora)
Build ID: 20140505080626

Steps to reproduce:

Login to gmail.com and open any email with a pdf attachment.


Actual results:

It gives "XML parsing error: undefined entity"


Expected results:

Show contents of the pdf file.

ZTE Open C with 1.3.0

Comment 1

4 years ago
I have tested using a flame master with today build (Gecko 692e97f Gaia f8755a2) and  when I try to open a email with a pdf attachment in the browser (gmail.com), I get the same error. 

Add screenshot about it.

Comment 2

4 years ago
Created attachment 8462439 [details]
screenshot_gmailPdf_browser.png
As email application had very limited support to see attachments and web sites can be a good option to check them, I think it is worthy to check:
1) why this bug appears still in master and
2) it is not properly downloaded by Download manager like other attachments.

Jason, do you know who is the best team to check it? Thanks in advance.
blocking-b2g: --- → 2.0?
Flags: needinfo?(jsmith)
Sorry wrong nomination.
blocking-b2g: 2.0? → ---
(In reply to Beatriz Rodríguez [:brg] from comment #3)
> As email application had very limited support to see attachments and web
> sites can be a good option to check them, I think it is worthy to check:
> 1) why this bug appears still in master and
> 2) it is not properly downloaded by Download manager like other attachments.
> 
> Jason, do you know who is the best team to check it? Thanks in advance.

Aus - What do you think?
Flags: needinfo?(jsmith) → needinfo?(aus)

Comment 6

4 years ago
As far as I can tell this isn't a Downloads API related issue. Looks like we really are failing to parse that content and that's what is used to display the attachment. If one uses the same link in Firefox Desktop, you'll get it to display as expected. Not sure why we would fail under FxOS.
Flags: needinfo?(aus)

Comment 7

4 years ago
I believe Ehsan knows more about this already (according to Fabrice).
Flags: needinfo?(ehsan)

Comment 8

4 years ago
I also saw this, and bug 1036987 now contains more technical information about the issue, so duping forwards.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ehsan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1036987

Comment 9

4 years ago
(And FTR, this has nothing to do with downloads.  The XHTML content they are sending down is not valid XML.)
You need to log in before you can comment on or make changes to this bug.