[Flame] Geolocation icon appears in status bar despite denying the permission via Camera App

RESOLVED INVALID

Status

Firefox OS
Gaia::System
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8434294 [details]
logcat

The Geolocation icon continues to appear in the homescreen status bar, despite "denying" usage of it when launching the camera app.   The geo Status icon should not even be shown if camera app is not asking for it.


See screencast for behavior:  http://youtu.be/UkE9OEVtIPY

ALso, logcat attached.

Repro:
1) install 2.0 nightly on Flame
Gaia      1d4f6f7312882e78b57971152de75d1281a26187
Gecko     https://hg.mozilla.org/mozilla-central/rev/668f29cd71b3
BuildID   20140604040204
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

2) launch camera app, and "Uncheck" option to use Geolocation
3) click "Share" to save the setting
4) Take a picture.   You can launch EXIF viewer later to verify that picture doesnt have geolocation coordinates
5) close the camera app and go to homescreen
6) Watch the status bar at the top.  Verify the geolocation icon is visible, then slowly animates and disappears.

Expected:
- since Geolocation was not granted for the camera app, i should not expect the geolocation icon to even appear on the status bar.

ActuaL:
- Geolocation icon appears in status bar, despite disallowing the permission to use it.
(Reporter)

Comment 1

4 years ago
ni? tim or alive to assist with investigation.
Flags: needinfo?(timdream)
Flags: needinfo?(alive)
Leaving QA Wanted to check 1.4.
Keywords: qawanted
(Reporter)

Comment 3

4 years ago
it's also reproduces on 1.4.

Gaia      233dd43b3b976e66a619dbc1b4044ed1e3ca3e34
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/c3c0c57daef8
BuildID   20140522000200
Version   30.0
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

lets keep qawanted back to 1.3 to check.
Keywords: qawanted
(Reporter)

Updated

4 years ago
Keywords: qawanted
I can't reproduce this issue electing "Don't Share" option.  The STRs in Comment 0 and in the video don't match the expected results.  No Geolocation icon is being shown in status bar after choosing not to share geolocation with the Camera App and taking a picture.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140604040204
Gaia: 1d4f6f7312882e78b57971152de75d1281a26187
Gecko: 668f29cd71b3
Version: 32.0a1 (2.0) 
Firmware Version: v10G-2

User Agent:  Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: qawanted
Resolution: --- → INVALID
I know what happened here.

Tony - You disabled remember my choice, but did still share geolocation with the camera app. That means geolocation would be shared with the camera app, which would result in the geolocation icon showing in the status bar. Disabling remember my choice just means that if I launch the camera app again that is currently not running in the background, then I'll get a geolocation prompt again & not have the decision I made previously remembered.
Flags: needinfo?(timdream)
Flags: needinfo?(alive)

Updated

4 years ago
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.