Closed Bug 1020527 Opened 6 years ago Closed 6 years ago

[Flame] Veritcal homescreen is essentially unusable

Categories

(Core :: Graphics: Layers, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
2.0 S3 (6june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: dhylands, Unassigned)

References

Details

(Keywords: regression, smoketest)

I just updated to the latest, and my homescreen is essentially unusable.

I'm running the 10G2 base image on my flame.
gaia: 0410f2a60cd68ebf0e3f5151404fefe38d1ad5df
gecko: (b2G-inbound) 186555:fd5bb34861d6

I've taken a video showing the problem, and as soon at it finishes uploading, I'll add a link.

I see the icons flash for about one frame time on the screen, and then they disappear. If I scroll around, I can see them flash from time to time. If I push on the screen where I last saw the icon, then I can launch the app.
This seems like a gecko regression. It also happens with FTU and it started when I updated gecko to trunk.
It seems like it came with this merge: https://hg.mozilla.org/integration/b2g-inbound/pushloghtml?startID=7625&endID=7626
Flags: needinfo?(milan)
blocking-b2g: --- → 2.0?
For the window here - you'll want to bisect on b2g-inbound builds.
QA Contact: jmercado
(In reply to Gregor Wagner [:gwagner] from comment #2)
> This seems like a gecko regression. It also happens with FTU and it started
> when I updated gecko to trunk.

Agreed. The issue does not occur with those versions: 
Gaia      0410f2a60cd68ebf0e3f5151404fefe38d1ad5df
Gecko     https://hg.mozilla.org/integration/b2g-inbound/rev/92c632eb4fa7
BuildID   20140604083010
Version   32.0a1

After this version of gecko, there are 2 new commits: da292113dc5b and fd5bb34861d6
Component: Gaia::Homescreen → Graphics
Product: Firefox OS → Core
See Also: → 1020569
Duplicate of this bug: 1020569
See Also: 1020569
(In reply to Gregor Wagner [:gwagner] from comment #3)
> It seems like it came with this merge:
> https://hg.mozilla.org/integration/b2g-inbound/
> pushloghtml?startID=7625&endID=7626

CCing people who landed gfx related stuff in that window.
It's somewhere between c19d5dcd5759 (broken) and 8dc53499b0c0 (works)
Bug 1015332 is the cause of the regression. I locally backed out the change and the regression is fixed.
You can prevent the regression by disabling hw composer from setting app.
(In reply to Sotaro Ikeda [:sotaro] from comment #9)
> Bug 1015332 is the cause of the regression. I locally backed out the change
> and the regression is fixed.

We need to back out Bug 1015332. Can someone back out it?
(In reply to Sotaro Ikeda [:sotaro] from comment #11)
> (In reply to Sotaro Ikeda [:sotaro] from comment #9)
> > Bug 1015332 is the cause of the regression. I locally backed out the change
> > and the regression is fixed.
> 
> We need to back out Bug 1015332. Can someone back out it?

On it!
blocking-b2g: 2.0? → 2.0+
Component: Graphics → Graphics: Layers
Fixed via backout - https://hg.mozilla.org/mozilla-central/rev/951e3a671279.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Flags: needinfo?(milan)
Target Milestone: --- → 2.0 S3 (6june)
You need to log in before you can comment on or make changes to this bug.