Closed Bug 1020616 Opened 5 years ago Closed 3 years ago

Ensure form and document are valid at start of requestAutocomplete

Categories

(Toolkit :: Form Manager, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: bnicholson, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: p=2 [qa-])

Basic checks to make sure that the form is allowed to trigger a requestAutocomplete. Namely, that the form has an active document, and the form's autocomplete attribute is not "off".

We'll need bug 1020602 first for testing, where calling the mock UI component will be used to verify that the form was valid.
(In reply to Brian Nicholson (:bnicholson) from comment #0)
> We'll need bug 1020602 first for testing

Think I meant bug 1020495.
Depends on: 1020495
No longer depends on: 1020602
We should also have tests for the form not having a window, which can happen as described in https://bugzilla.mozilla.org/show_bug.cgi?id=1020440#c6:
> The issue is that .defaultView returns null for data documents, 
> so the js code would throw an exception for
> document.implementation.createHTMLDocument().createElement("form").
> requestAutocomplete();
Flags: firefox-backlog+
Whiteboard: p=2 → p=2 [qa-]
Assignee: bnicholson → nobody
Status: ASSIGNED → NEW
requestAutocomplete was removed from the HTML specification.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.