Closed Bug 1020653 Opened 6 years ago Closed 6 years ago

[B2G] [Messaging] Device doesn't vibrate or chime when receiving an SMS while locked

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.4 unaffected, b2g-v2.0 affected)

RESOLVED DUPLICATE of bug 1023642
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- affected

People

(Reporter: ckreinbring, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [2.0-flame-test-run-1], [2.0-flame-test-run-2], [FT:System-Platform])

Attachments

(1 file)

Description:
If a device is locked with the notification sound muted, the device will not vibrate when an SMS is received.

Repro Steps:
1) Update Flame to Build ID: 20140604040204
2) On the Settings > Sound page, make sure Vibrate is on and the Ringer & Notifications slider is all the way to the left.
3) Return to the homescreen and lock the device.
4) On a second device send an SMS to the first device.
5) Press the power button on the first device and observe what the device does when the SMS is received.

Actual:
The SMS appears but the device does not vibrate.

Expected:
The SMS appears and is accompanied by a short vibration from the device.

Environmental Variables
Device: Flame 2.0
Build ID: 20140604040204
Gecko: https://hg.mozilla.org/mozilla-central/rev/668f29cd71b3
Gaia: 1d4f6f7312882e78b57971152de75d1281a26187
Platform Version: 32.0a1
Firmware Version: V10g-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/4987/
See attached logcat logs
Also repros on today's Open C 2.0 and Buri 2.0 mozilla RIL.  Does not repro on Flame 1.4 or on the May 30 Flame 2.0 build.  On these versions the device vibrated when it received an SMS while muted and on the lock screen.

Repro
Open C 2.0
Build ID: 20140604040204
Gecko: https://hg.mozilla.org/mozilla-central/rev/668f29cd71b3
Gaia: 1d4f6f7312882e78b57971152de75d1281a26187
Platform Version: 32.0a1
Firmware Version: P821A10v1.0.0806_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Buri 2.0
Build ID: 20140604040204
Gecko: https://hg.mozilla.org/mozilla-central/rev/668f29cd71b3
Gaia: 1d4f6f7312882e78b57971152de75d1281a26187
Platform Version: 32.0a1
Firmware Version: V1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


No Repro
Flame 2.0
Build ID: 20140530040207
Gecko: https://hg.mozilla.org/mozilla-central/rev/e6f113c83095
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Platform Version: 32.0a1
Firmware Version: V10g-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4
Build ID: 20140604000202
Gecko: https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/04216748e6c1
Gaia: 0c16adced7c51f795ef250aebe184f60b6a9b987
Platform Version: 30.0
Firmware Version: V10g-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
blocking-b2g: --- → 2.0?
Upon further investigation, it's been found that the notification sound does not play if the device is locked.
Summary: [B2G] [Messaging] Device doesn't vibrate when receiving an SMS while muted and locked → [B2G] [Messaging] Device doesn't vibrate or chime when receiving an SMS while locked
blocking-b2g: 2.0? → 2.0+
Can you please write the right STR again, then?
Flags: needinfo?(ckreinbring)
STR:

1) Update Flame to Build ID: 20140604040204
2) While on the homescreen, lock the device.
3) On a second device send an SMS to the first device.
4) Press the power button on the first device and observe what the device does when the SMS is received.

Actual:
The SMS appears but the device does not vibrate or play the notification sound.

Expected:
The SMS appears and is accompanied by a notification sound and a short vibration from the device.
Flags: needinfo?(ckreinbring)
Thanks. FTR I see the same on Buri (recent v2.0) too but not in Peak v1.4 (slightly old build).

Let's see what the regression window will be.
QA Contact: rkunkel
Hey Jason, any chance you can make that regression window happen?
Flags: needinfo?(jsmith)
Joshua - Can you get someone assigned here?
Flags: needinfo?(jsmith) → needinfo?(jmitchell)
Hi guys - Roland Kunkel has already snagged QA-Contact on this (between comment 5 and 6) and is currently working on the window; it should be complete soon.
Flags: needinfo?(jmitchell)
Regression Window:


Last Working:
Environmental Variables:
Device: Flame 2.0
BuildID: 20140603023003
Gaia: 969d35114eed0eabbd0fe7c01fad19a2df0097b5
Gecko: 8b3454b9896d
Version: 32.0a1
Firmware Version: V10G-2


First Broken:
Environmental Variables:
Device: Flame 2.0
BuildID: 20140603053003
Gaia: cdaf998934f4924a4b256ed5458b484818a01948
Gecko: 7fba4f8ca783
Version: 32.0a1
Firmware Version: V10G-2


Last Working Gaia First Broken Gecko: Issue did NOT reproduce
Gaia: 969d35114eed0eabbd0fe7c01fad19a2df0097b5
Gecko: 7fba4f8ca783

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: cdaf998934f4924a4b256ed5458b484818a01948
Gecko: 8b3454b9896d

This indicates a Gaia issue
https://github.com/mozilla-b2g/gaia/compare/969d35114eed0eabbd0fe7c01fad19a2df0097b5...cdaf998934f4924a4b256ed5458b484818a01948
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
IMO the only thing that makes sense in this window is the lockscreen refresh (bug 950884).

NI me to look at the actual code we use in SMS and see what could have changed.
Flags: needinfo?(felash)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Blocks: 950884
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1], [FT:System-Platform]
Oh, OK, I know.

if the notification is displayed, then the sound+vibration are done by the System app, not the SMS app. So if there is a notification (and I understand there is one), this is definitely a System issue.

So the LockScreen refresh is the likely culprit.
Component: Gaia::SMS → Gaia::System
Flags: needinfo?(felash)
Whiteboard: [2.0-flame-test-run-1], [FT:System-Platform] → [2.0-flame-test-run-1], [2.0-flame-test-run-2], [FT:System-Platform]
Looks like this is a dupe from bug 1023642. It has now landed, so it should be fixed. Please reopen if the issue persists after checking your Gaia has the fix for bug 1023642.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1023642
blocking-b2g: 2.0+ → ---
You need to log in before you can comment on or make changes to this bug.