Closed Bug 1020747 Opened 8 years ago Closed 7 years ago

sp.nhknews.jp/sp/ sent a -webkit- only CSS properties to smartphones

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: karlcow, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [mobile-compat-form] [country-jp] [contactready] [webkitcss])

Attachments

(1 file)

Site: http://sp.nhknews.jp/sp/index.php
sp.nhknews.jp/sp/ sent a -webkit- only CSS properties to smartphones

:: Steps To Reproduce

1. With Firefox on Android with a fake Chrome User agent
2. Go to http://sp.nhknews.jp/sp/index.php


:: Expected Result

The site is displayed as for Chrome Mobile

:: Actual Result

Some CSS properties have been made for Webkit devices only. Most of them are quite easy to fix. Linear gradient, box shadow, etc. And the site would be usable on many more devices.

:: Additional Information

Software Version: 30
Device Information: GT-i9100
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: Other → ARM
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [country-jp] [contactready] [webkitcss]
Blocks: 1020740
Blocks: 1020733
Attached image nhknews-paywall.png
note that they changed their strategy. And now instead of sending us a mobile site, they are blocking us.

> お使いの機種では本サービスをご利用頂けません。		
> 本サービスはAndroidの標準ブラウザ、もしくはiPhoneの場合は
> Safariからのご利用をお願いしております。Androidの標準
> ブラウザ及びiPhoneのSafari以外をお使いの場合、
> この画面が表示される場合があります。お問合せ先
> nhknews2@nhk-gmobile.jp	

Anything which is not specifically in their target list they ignore. Example with Chrome on Mobile here.


→ http --print hH http://sp.nhknews.jp/sp/index.php 'User-Agent:Mozilla/5.0 (Linux; Android 4.3; HTCONE Build/JSS15J) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.59 Mobile Safari/537.36'
GET /sp/index.php HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Connection: keep-alive
Host: sp.nhknews.jp
User-Agent: Mozilla/5.0 (Linux; Android 4.3; HTCONE Build/JSS15J) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.59 Mobile Safari/537.36

HTTP/1.1 302 Found
Connection: Keep-Alive
Content-Length: 0
Content-Type: text/html; charset=Shift_JIS
Date: Tue, 09 Jun 2015 05:02:57 GMT
Keep-Alive: timeout=5, max=100
Location: http://sp.nhknews.jp/sp/NotSupport.php
Server: Apache/2.2.10 (Win32)
X-Pad: avoid browser bug



On the other hand… this is working

→ http --print hH http://sp.nhknews.jp/sp/index.php 'User-Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 7_0 like Mac OS X) AppleWebKit/546.10 (KHTML, like Gecko) Version/6.0 Mobile/7E18WD Safari/8536.25'
GET /sp/index.php HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Connection: keep-alive
Host: sp.nhknews.jp
User-Agent:  Mozilla/5.0 (iPhone; CPU iPhone OS 7_0 like Mac OS X) AppleWebKit/546.10 (KHTML, like Gecko) Version/6.0 Mobile/7E18WD Safari/8536.25

HTTP/1.1 200 OK
Connection: Keep-Alive
Content-Type: text/html; charset=Shift_JIS
Date: Tue, 09 Jun 2015 05:04:29 GMT
Keep-Alive: timeout=5, max=100
Server: Apache/2.2.10 (Win32)
Transfer-Encoding: chunked



The sad story here… is that when Faking the UA to be iPhone. The site homepage is working…
The issue starts when we ask for a secondary page such as
http://sp.nhknews.jp/sp/news/Special/Page.php?p=P0036748

Here we are being redirected to an intermediate paywall login page
See the screenshot

They propose the choice of 3 operators in Japan to subscribe to the service.
I'm changing the nature of the bug. The -webkit- is not apparent.
The site is blocked because we don't have access to the paywall without being a customer of the 3 operators. sp, au, Softbank
Summary: sp.nhknews.jp/sp/ sent a -webkit- only CSS properties to smartphones → sp.nhknews.jp/sp/ is blocked because they support a couple of phones only
Whiteboard: [mobile-compat-form] [country-jp] [contactready] [webkitcss] → [mobile-compat-form] [country-jp] [contactready] [serversniff]
Let's change back to webkit css. And putting it as FIXED.

The blocking is in Bug 1020740
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Summary: sp.nhknews.jp/sp/ is blocked because they support a couple of phones only → sp.nhknews.jp/sp/ sent a -webkit- only CSS properties to smartphones
Whiteboard: [mobile-compat-form] [country-jp] [contactready] [serversniff] → [mobile-compat-form] [country-jp] [contactready] [webkitcss]
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.