(vertical-homescreen) Status bar should become 100% opaque when user scrolls

RESOLVED FIXED

Status

Firefox OS
Gaia::Homescreen
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Peter La, Assigned: crdlc)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(b2g-v2.0 fixed)

Details

(Whiteboard: ux-tracking, visual design, visual-tracking, [ft:systemsfe][systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
When the user scrolls the rocketbar and icon grid up under the status bar, the status bar should become 100% opaque according to the spec.

Please see Scenario 2 from the spec:
https://mozilla.box.com/s/2wf017uxi7wmxme489kd

I will also be attaching a video showing this in action.
(Reporter)

Comment 1

4 years ago
Created attachment 8434666 [details]
Vertical Scroll.mp4

This is the expected behaviour of statusbar on vertical scroll.  It should also transition back to being transparent if the user scrolls all the way back to the top of the screen (and the rocketbar is no longer tucked under the statusbar).  The fade duration would be the same in that case, but going from 100% opaque to 15% opaque.
(Assignee)

Comment 2

4 years ago
I try to prototype it today
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 3

4 years ago
Created attachment 8434841 [details]
Github pull request

The features is already implemented but before doing something regarding to unit test I would like to know your feedback about the solution implemented
Attachment #8434841 - Flags: feedback?(kgrandon)
Attachment #8434841 - Flags: feedback?(alive)
Comment on attachment 8434841 [details]
Github pull request

I wish there was another way. Unfortunately that we also need to do this for some dialogs and maybe smart collections I don't really see a way around the IAC message for now.

I would really love to see a marionette tests for this, but seems that might be a bit tricky to do, so a follow-up is fine.
Attachment #8434841 - Flags: feedback?(kgrandon) → feedback+
Comment on attachment 8434841 [details]
Github pull request

I wonder why we don't use mozbrowserscroll here.
Attachment #8434841 - Flags: feedback?(alive)
After trying, mozbrowserscroll seems not working on homescreen,
Ben do you know the story? Is mozbrowserscroll failing on apz enabled mozbrowser iframe?
Flags: needinfo?(bfrancis)
We can't use mozbrowserscroll because this is inside of an overflow-y div. It's like this because we also need to show the scroll bar. There may be some platform patches we can do to also show the scrollbar, but we'd still need some hook into the statusbar background (when showing dialogs, etc).
Flags: needinfo?(bfrancis)
(In reply to Kevin Grandon :kgrandon from comment #7)
> We can't use mozbrowserscroll because this is inside of an overflow-y div.
> It's like this because we also need to show the scroll bar. There may be
> some platform patches we can do to also show the scrollbar, but we'd still
> need some hook into the statusbar background (when showing dialogs, etc).

Well I am concern why UX designs this...statusbar is really not part of homescreen.
For dialog it would be easy if the dialog is trigger by some mozbrowser events or mozChromeEvent and system app could jump in.
I guess we don't really have the events we need today, and are trying to fill this with IAC messages. I agree it is not ideal, but I'm not sure what options we have for 2.0 =/
Comment on attachment 8434841 [details]
Github pull request

It seems I could only f+.
Attachment #8434841 - Flags: feedback+
(Assignee)

Comment 11

4 years ago
Comment on attachment 8434841 [details]
Github pull request

Ready to review and added a marionette test
Attachment #8434841 - Flags: review?(kgrandon)
Attachment #8434841 - Flags: review?(alive)
Comment on attachment 8434841 [details]
Github pull request

r+ for system app part.
Attachment #8434841 - Flags: review?(alive) → review+
(Assignee)

Comment 13

4 years ago
Thanks a lot Alive

(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #12)
> Comment on attachment 8434841 [details]
> Github pull request
> 
> r+ for system app part.
Comment on attachment 8434841 [details]
Github pull request

I can't quite give R+ on this yet, there's some problems with the transition. When I scroll down, I see that the background appears to start from the bottom of the statusbar, then expand upwards (seems like the direction could be wrong).

I'll give the code a look to see if I can figure out exactly why. I think we are close, we just need to fix that transition.
Attachment #8434841 - Flags: review?(kgrandon)
Comment on attachment 8434841 [details]
Github pull request

Ok, I am gonna update one transform origin and we should be good. Thanks!
Attachment #8434841 - Flags: review+
Landed: https://github.com/mozilla-b2g/gaia/commit/637213e32deb42b051acf6e47755518a8baad34c
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Mass modify - set status-b2g-v2.0 fixed for fixed bugs under vertical homescreen dependency tree.
status-b2g-v2.0: --- → fixed
You need to log in before you can comment on or make changes to this bug.