Closed Bug 1021237 Opened 7 years ago Closed 7 years ago

Edge Swipe Gesture - Inconsistencies triggering in landscape on Flame

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rmacdonald, Assigned: etienne)

References

Details

Attachments

(2 files)

When triggering the edge swipe gesture in landscape mode on Flame, the swipe gesture does not seem to respond when attempted to swipe from the top or bottom of the left and right edges.

STR
1) Launch a few apps then launch Browser
2) Hold the device in landscape orientation
3) Attempt to swipe from the left edge or right edge of the screen

Actual Behaviour
- Swipe activation does not seem to work from to top or bottom areas of the left and right edges

Intended Behaviour
- Swipe should be activated across the full edge.
Can we get a video of the bug here?
Component: Gaia → Gaia::System::Window Mgmt
Keywords: qawanted
Hum... the edge zones are pretty small in landscape mode.
We should probably make them taller. Especially since you tend to swipe close to the top or close to the bottom in landscape in order to avoid the home button.
This patch makes things better.

But there's also a hardware side of this.
If you move your finger quickly in portrait mode, there's not enough bezel for you to start outside of the touch sensitive zone so we always get the touch events.
But in landscape, when you start your gesture outside of the touch sensitive zone, if you go slowly we get the touch events, but if you go fast we don't get anything.
Attachment #8435503 - Flags: review?(21)
https://github.com/mozilla-b2g/gaia/commit/878ed9bd337e952007bb606632a803390dae5d8b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.