[camera] self-timer icon is blank

RESOLVED FIXED

Status

Firefox OS
Gaia::Camera
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: tif, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: interaction-design [2.0-FL-bug-bash] )

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
STR: 

1. Launch Camera app
2. Go to Options menu and enable Self-Timer to any time

Expected
Indicator onscreen has self-timer image in it

Actual
There is an empty what square for the indicator
(Reporter)

Updated

4 years ago
Whiteboard: interaction-design
(Reporter)

Comment 1

4 years ago
Created attachment 8435422 [details]
blank self-timer icon

Updated

4 years ago
Whiteboard: interaction-design → interaction-design [2.0-FL-bug-bash]
This regressed because of this commit: https://github.com/mozilla-b2g/gaia/commit/b303dbf72b9523f4a74ec055e18c943fb289ff82

I flagged this in review [1], but dmarcos must have missed it.

[1] https://github.com/dmarcos/gaia/pull/80/files#r13174028
Flags: needinfo?(dmarcos)

Updated

4 years ago
Blocks: 998362
Keywords: regression
Assuming that the timer still works here, I think this is worth fixing, but probably not a blocking issue.
Created attachment 8436587 [details] [review]
Pull Request

We refer self-timer everywhere in the app and I changed the name of the icon to have consistency: icon-timer -> icon-self-timer

I forgot to also change the class name in the indicators view template. The attached PR fixes the issue. There are two commits:

1. It changes all the lines because this file still had windows end of lines.
2. It changes the css class name needed to fix the bug.
Attachment #8436587 - Flags: review?(wilsonpage)
Flags: needinfo?(dmarcos)
Comment on attachment 8436587 [details] [review]
Pull Request

Code looks good, assumed working. Just needs a squash :)
Attachment #8436587 - Flags: review?(wilsonpage) → review+
Landed in master:

https://github.com/mozilla-b2g/gaia/commit/86da626923719d6550b4e0fccc67af27f96a02e4
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

4 years ago
Awesome! Thanks Diego!
You need to log in before you can comment on or make changes to this bug.