[VsD Refresh] Lockscreen Visual Refresh > Unlock icon too low

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Peter La, Assigned: mnjul)

Tracking

unspecified
2.0 S4 (20june)
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

(Whiteboard: ux-tracking, visual design, visual-tracking, bokken [ucid:SystemPlatform60, 2.0, ft:system-platform][2.0-FL-bug-bash] [p=1])

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8435421 [details]
LockIconTooLow.jpg

The unlock icon in the lockscreen looks too low visually.  It needs to be moved up 3 pixels to appear visually centered.  See attachment.
Assignee: nobody → jlu
Status: NEW → ASSIGNED

Updated

4 years ago
Whiteboard: ux-tracking, visual design, visual-tracking, bokken [ucid:SystemPlatform60, 2.0, ft:system-platform] → ux-tracking, visual design, visual-tracking, bokken [ucid:SystemPlatform60, 2.0, ft:system-platform][2.0-FL-bug-bash]
Created attachment 8435505 [details]
lock_screen_original.png
Created attachment 8435506 [details]
lock_screen_up2px_0.1rem.png
Created attachment 8435507 [details]
lock_screen_up3px_0.2rem.png
Comment on attachment 8435506 [details]
lock_screen_up2px_0.1rem.png

Hi Peter,

I did some CSS manipulation and it appeared that upping 2px (0.1rem) seems to be visually better than upping 3px (0.2rem). Please see my attachments. So I'd like to confirm if you want to go with 2px or 3px? Thanks :)
Attachment #8435506 - Flags: ui-review?(pla)
Whiteboard: ux-tracking, visual design, visual-tracking, bokken [ucid:SystemPlatform60, 2.0, ft:system-platform][2.0-FL-bug-bash] → ux-tracking, visual design, visual-tracking, bokken [ucid:SystemPlatform60, 2.0, ft:system-platform][2.0-FL-bug-bash] [p=1]
Target Milestone: --- → 2.0 S4 (20june)
(Reporter)

Comment 5

4 years ago
Comment on attachment 8435506 [details]
lock_screen_up2px_0.1rem.png

Hi John,

Appreciate your input, but I think I like the original ask to move it up 3 pixels better.
Attachment #8435506 - Flags: ui-review?(pla) → ui-review-
Attachment #8436644 - Flags: review?(gweng)
blocking-b2g: --- → 2.0?
Feel free to seek uplift when ready but this is not a blocker for release.
blocking-b2g: 2.0? → -
Comment on attachment 8436644 [details] [review]
Patch

Style changes, and tests passed. Go ahead and thanks for your help.
Attachment #8436644 - Flags: review?(gweng) → review+
Master: https://github.com/mozilla-b2g/gaia/commit/7ffd675e39e3e22283ed388b3faecdc3f0417962
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8436644 [details] [review]
Patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]

[Bug caused by] (feature/regressing bug #): bug 1021391 was because of not-to-spec implementation of bug 950884

[User impact] if declined: minimal, as this is only cosmetic change

[Testing completed]: Yes, both Travis and TBPL, with rebase against master just 1.5 hours ago

[Risk to taking this patch] (and alternatives if risky): minimal, as this is only cosmetic change

[String changes made]: None
Attachment #8436644 - Flags: approval-gaia-v2.0?

Updated

4 years ago
Attachment #8436644 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+

Updated

4 years ago
Blocks: 1020115
v2.0: https://github.com/mozilla-b2g/gaia/commit/dd7a86e2464091148216354d82d3516d800ceee2
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed

Comment 12

4 years ago
How is this approval+ with ui-review-? Please clarify.
(In reply to Stephany Wilkes from comment #12)
> How is this approval+ with ui-review-? Please clarify.

I assumed JOhn's patch addressed the UX comment and since it had landed on master with no further comments from anyone. If the patches are not ready, they should not be requesting approval.

Comment 14

4 years ago
Peter, can you verify whether ui-review is - or + here? Thank you!
Flags: needinfo?(pla)
Hi there,
the 3px upping was made into CSS in the patch and it looked like exactly in one of my screenshots.
(Reporter)

Comment 16

4 years ago
Hi Stephany/John,

I tried building your branch but I got an error.  Can you just post a screenshot?

Thanks,
Peter.
Flags: needinfo?(pla)
You need to log in before you can comment on or make changes to this bug.