Exception in debugger source view

RESOLVED DUPLICATE of bug 991179

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 991179
4 years ago
4 years ago

People

(Reporter: Luke, Unassigned)

Tracking

30 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140508142553

Steps to reproduce:

Switched debugger's page js file in the left panel.


Actual results:

It gave this instead of the js source in the textbox:

Could not load the source for javascript:self.on("click", function (junk) {self.postMessage("junk");});.
[Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIChannel.asyncOpen]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/main.js -> resource://gre/modules/devtools/server/actors/script.js :: fetch :: line 5218"  data: no]Line: 5218, column: 0


Expected results:

It should always show the source.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 991179
You need to log in before you can comment on or make changes to this bug.