Closed Bug 1021558 Opened 6 years ago Closed 4 years ago

[Homescreen] Homescreen will automatically move to last page

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: wachen, Unassigned)

References

Details

(Whiteboard: [2.0-FL-bug-bash])

Build Information

Device: Flame
Gaia      d2cfef555dabab415085e548ed44c48a99be5c32
Gecko     https://hg.mozilla.org/mozilla-central/rev/51b428be6213
BuildID   20140605040202
Version   32.0a1
ro.build.version.incremental=96
ro.build.date=Fri May 23 11:17:40 CST 2014

Description
If you keep creating new homescreens (horizontal), when you tried to go back to the first page, it will scroll back to last screen automatically

Steps to Reproduce
1. Move the apps to the rocketbar (max 7)
2. go to last homescreen
3. drag apps out from the rocketbar to new home pages
4. after releasing 7 apps, it will create 7 new homescreens
5. repeat 1~4 for 2~3 times
6. swipe all the way back to first page

Expected Results
It will stay on the first page

Actual Results
It will go back to the last page

Other Notes
Putting them under delete/move mode might be easier to reproduce this

Reproduction Frequency: about 30%
Can you provide a video to make the STR more clear?
Component: Gaia → Gaia::Homescreen
Summary: [Homescreen] Homescreen will automatically move to last page → [Vertical Homescreen] Homescreen will automatically move to last page
User Story: (updated)
Flags: needinfo?(wachen)
Blocks: 1015336
QA Whiteboard: [VH-FL-blocking-]
Due to the "horizontal" wording in the first comment, I'm going to assume that this is in the old homescreen. Unblocking bug 1015336, but we can re-block if we get more details.
No longer blocks: 1015336
Yes, it is the old homescreen, sorry for the confusing.
Flags: needinfo?(wachen)
Summary: [Vertical Homescreen] Homescreen will automatically move to last page → [Homescreen] Homescreen will automatically move to last page
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.