If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pushing a commit to a closed tree should enter a queue that (when trivial) automatically rebases and commits

RESOLVED DUPLICATE of bug 910028

Status

Developer Services
Mercurial: hg.mozilla.org
RESOLVED DUPLICATE of bug 910028
3 years ago
3 years ago

People

(Reporter: cwiiis, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
Almost every time I want to push something to inbound the tree seems closed - Although this probably isn't the case, it means I often forget to push a patch, or forget until the point where I have to rebase and possibly re-review.

Ideally, pushing to a closed tree would enter your patch into a queue, that when the tree reopens, would get rebased and committed automatically.

If that is deemed too risky, it could even just fail if it requires any kind of rebasing.

Having to monitor the state of the tree and re-push and contend with other people doing the same thing takes up a non-trivial amount of my time and it feels this could be solved with automation.
I think we'll fix this with autoland in one way or another. e.g. normal workflow wouldn't involve pushing to inbound directly, you'd have your code on a dev branch somewhere (like try), and autoland would transplant it to inbound automagically after tests and reviews passed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 910028
(Assignee)

Updated

3 years ago
Product: Release Engineering → Developer Services
You need to log in before you can comment on or make changes to this bug.