Closed Bug 1021732 Opened 6 years ago Closed 5 years ago

[Flame] Re-enable test_privileged_app_contacts_prompt

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected)

RESOLVED FIXED
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: AndreiH, Assigned: viorela)

References

Details

Attachments

(6 files)

The test started to fail in:

http://selenium.qa.mtv2.mozilla.com:8080/view/B2G%20Flame/job/b2g.flame.mozilla-central.ui.non-smoketest/54/HTML_Report/

Needs to be investigated.

Traceback (most recent call last):
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.7-py2.7.egg/marionette/marionette_test.py", line 163, in run
    testMethod()
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/system/test_privileged_app_contacts_prompt.py", line 28, in test_contact_prompt
    permission.wait_for_permission_dialog_displayed()
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/regions/permission_dialog.py", line 17, in wait_for_permission_dialog_displayed
    self.wait_for_element_displayed(*self._permission_dialog_locator)
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 42, in wait_for_element_displayed
    lambda m: m.find_element(by, locator).is_displayed())
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.7-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TimeoutException: TimeoutException: Timed out after 20.1 seconds
It seems that the "permission dialog" is not shown anymore after tapping on "Insert fake contacts".

STR:

1. Open UI tests app
2. Tap on Contacts
3. Tap on Insert fake contacts

Before there was a warning message that appeared: UI tests - Privileged App would like to access your contact list.

Is this intended?
Flags: needinfo?(jsmith)
Whiteboard: [qawanted]
It definitely sounds like a regression Andrei!
No - this is a regression, and a bad one at that.

Is this working on 1.4?
blocking-b2g: --- → 2.0?
Component: Gaia::UI Tests → DOM: Apps
Flags: needinfo?(jsmith)
Product: Firefox OS → Core
Whiteboard: [qawanted]
Version: unspecified → Trunk
This is not reproducible on v1.4 latest build:

Gaia      183efb374be1bcbf92f1fb3d0212a68b564a6d3e                         
Gecko  https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/960c48b5a5fa                                                                         
BuildID   20140606000204                                                   
Version   30.0                                                             
ro.build.version.incremental=94                                            
ro.build.date=Tue May 20 09:29:20 CST 2014
This is actually intended if the app is a preinstalled one. See bug 1014410
Discussed in IRC - bug 1014410 changes the behavior here, so we need to update the UI automation for privileged app tests to make sure that the relevant privileged APIs are set to prompt before running the test.
blocking-b2g: 2.0? → ---
Component: DOM: Apps → Gaia::UI Tests
Product: Core → Firefox OS
Version: Trunk → unspecified
Whiteboard: [fromAutomation]
Removing the tag, this remains for tracking test changes
Whiteboard: [fromAutomation]
Assignee: nobody → zcampbell
I've updated the test but found a bug: bug 1024513.

I'll xfail and update the test at the same time.
Depends on: 1024513
Summary: [Flame][v2.0] test_privileged_app_contacts_prompt is failing on flame → [Flame] Update test_privileged_app_contacts_prompt to match new prompt behaviour
Attached file github pr
Attachment #8439230 - Flags: review?(robert.chira)
Keywords: regression
Attachment #8439230 - Flags: review?(robert.chira) → review+
Attachment #8440649 - Flags: review?(florin.strugariu) → review+
Assignee: zcampbell → nobody
Summary: [Flame] Update test_privileged_app_contacts_prompt to match new prompt behaviour → [Flame] Re-enable test_privileged_app_contacts_prompt
Assignee: nobody → viorela.ioia
Bug 1024513 is fixed, so we can re-enable the test
Attachment #8453024 - Flags: review?(florin.strugariu)
Attachment #8453024 - Flags: review?(andrei.hutusoru)
Attachment #8453024 - Flags: review?(florin.strugariu) → review+
Attachment #8453024 - Flags: review?(andrei.hutusoru)
We need to re-enable the test on v2.0 too
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #8453798 - Flags: review?(florin.strugariu)
Viorela can you please investigate also why it's failing on Travis:
https://travis-ci.org/mozilla-b2g/gaia/jobs/29585963

It is constantly failing.
(In reply to [:AndreiH] from comment #17)
> Viorela can you please investigate also why it's failing on Travis:
> https://travis-ci.org/mozilla-b2g/gaia/jobs/29585963
> 
> It is constantly failing.

Reverted it:
https://github.com/mozilla-b2g/gaia/commit/e347a0f1ffa02d5a4feb21dfbe3ffb69b6768c87

Let's investigate why it's failing on master first.
Duplicate of this bug: 1036996
Depends on: 1037030
Viorela can you take a new look over this issue as it was reverted.
Flags: needinfo?(viorela.ioia)
Attachment #8453798 - Flags: review?(florin.strugariu)
Bebe, there's bug Bug 1037030 opened for this issue.
Flags: needinfo?(viorela.ioia)
Bug 1037030 is fixed, I run the test on both device and desktopb2g and it passes
Attachment #8459615 - Flags: review?(florin.strugariu)
Attachment #8459615 - Flags: review?(florin.strugariu) → review+
https://github.com/mozilla-b2g/gaia/commit/b6e702681a3b7d440d55e1decffd9672f7561e04
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Unxfailed test_contact_prompt on v2.0
Attachment #8470814 - Flags: review?(viorela.ioia)
Attachment #8470814 - Flags: review?(viorela.ioia) → review+
You need to log in before you can comment on or make changes to this bug.