[B2G][Tarako][Email] Message list's sender name may have very little whitespace between it and the message relative timestamp (ex: long name and long relative name of "a minute ago").

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::E-Mail
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Montoya Clemmons (MClemmons), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected, b2g-v1.3T affected, b2g-v1.4 affected)

Details

(Whiteboard: [tarako-exploratory])

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8436000 [details]
Firewatch Email Log

User sets up an email account and receives a message with a name that contains 16 characters (including spaces). When initially received, the inbox shows the name in bold on the left and to its right in blue the message 'just now' on the right. However, when the blue messaging changes to a minute ago, the last character of the sender of the message is directly to the left of that messaging. The ellipsis follows part of the sender's name only after the blue messaging changes to 2 minutes ago.

Prerequisites:
1. Setup email account on device without manual setup 

Repro Steps: 
1) Update a Tarako to BuildID: 20140606014002
2) Tap Email App
3) Have an email sent to test device with a name that is 16 characters (with spaces – i.e. Montoya Clemmons
4) Sync device and observe device behavior 

Actual: 
When received, inbox displays 'Montoya Clemmons' then significant space and the blue message 'just now'. Once the blue message changes to 'a minute ago', the 's' in “Clemmons” is to the immediate left of 'a minute ago' with no spacing. (See screenshot)

Expected: 
Once blue message changes to 'a minute ago' the last name 'Clemmons' changes to Clemm with an ellipsis, such as 'Clemm...'  

Notes: 
Repro frequency: (5/5, 100%) 

See attached: screenshot, logcat, firewatch

The type of device in use
Tarako

The "Build Identifier" of the build you are using
20140606014002 

Confirm the net connection is working
Confirmed

The e-mail domain you used/are using to create the account
hotmail.com and gmail.com 

If this is not a problem creating the account, the account type the e-mail client thinks it is using
hotmail.com – activesync 
gmail.com - imap+smtp

Environmental Variables:
Device: Tarako 1.3T
Build ID: 20140606014002
Gaia: 33025a8b1e458ef48cb8b7fb81bdaba28c86b183
Gecko: 161d4b0448c6
Version: 28.1 (1.3T) 
Firmware Version: SP6821a-Gonk-4.0-5-12
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
(Reporter)

Comment 1

4 years ago
Update to Environmental Variables in Comment 0.

Environmental Variables:
Device: Tarako 1.3T
Build ID: 20140606014002
Gaia: 33025a8b1e458ef48cb8b7fb81bdaba28c86b183
Gecko: 161d4b0448c6
Version: 28.1 (1.3T) 
Firmware Version: SP6821a-Gonk-4.0-5-12
User Agent: Mozilla/5.0 (Mobile; rv:28.1) Gecko/28.1 Firefox/28.1
(Reporter)

Comment 2

4 years ago
This issue reproduces on 1.3 Buri following the STR in Comment 0. When received, inbox displays sender name then significant space and the blue message 'just now'. Once the blue message changes to 'a minute ago', final character in sender's name is to the immediate left of 'a minute ago' with no spacing. 

Environmental Variables:
Device: Buri 1.3
Build ID: 20140605024002
Gaia: 2408c2238254776b0d3716753b7bf917883c9915
Gecko: 6214d9d288e3
Version: 28.0 (1.3) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
status-b2g-v1.3: --- → affected
(Reporter)

Comment 3

4 years ago
Created attachment 8436014 [details]
Screenshot of Issue Reported
(Reporter)

Comment 4

4 years ago
Created attachment 8436016 [details]
Logcat Email Issue
(Reporter)

Comment 5

4 years ago
Created attachment 8436018 [details]
Screenshot of Ellipsis after 3 minutes
(Reporter)

Comment 6

4 years ago
This issue reproduces on 1.4 Flame following the STR from Comment 0. When received, inbox displays sender name then significant space and the blue message 'just now'. Once the blue message changes to 'a minute ago', final character in sender's name is to the immediate left of 'a minute ago' with no spacing. 

Flame 1.4
Build ID: 20140606000204
Gecko: https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/960c48b5a5fa
Gaia: 183efb374be1bcbf92f1fb3d0212a68b564a6d3e
Platform Version: 30.0
Firmware Version: V10g-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
status-b2g-v1.4: --- → affected
I was expecting "bumps into" to mean that there was visual overlap, however this appears to be a case of there being effectively no whitespace between the two (~1 px) which is arguably less bad.

:jrburke just implemented our VD overhaul for 2.0.  I would propose that he checks to see if we've improved this on trunk / whether the VD specifies minimal spacing and then follow-up with UX/VD as appropriate.  This change wouldn't be hard to uplift to earlier versions, but it might make sense to only address this on 2.0/trunk.
Flags: needinfo?(jrburke)
Summary: [B2G][Tarako][Email]Inbox display with name of sender with 16 characters bumps into blue message of a minute ago for Hotmail and Gmail accounts → [B2G][Tarako][Email] Message list's sender name may have very little whitespace between it and the message relative timestamp (ex: long name and long relative name of "a minute ago").
Created attachment 8438035 [details]
Capture of flame and hamachi 2.0 refresh

Attached is an image that shows Flame and Hamachi in the 2.0 design. I think it looks fine, better than what is shown in the other screenshot in this bug, so I believe this is "fixed" for 2.0.

I would prefer to not address it in the other versions, as it is still usable, just a bit tight, and trying to limit further changes on those older branches. But leave it to QA to scrub to the correct bucket.
Flags: needinfo?(jrburke)
Thanks, I agree 2.0 seems good enough and we'll leave it to UX/VD to file a specific bug with a specific fix if they disagree in their use of the phone.

I believe strongly in keeping open bugs relevant, so I'll tentatively WFM this since I don't think duping is significantly more helpful.  :jsmith/others, feel free to bin (more) appropriately.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.