[B2G][Tarako][Music]Ending incoming call without answering while Music App is playing causes 2-3 second delay from paused music to re-started music

RESOLVED INVALID

Status

defect
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: mclemmons, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 unaffected, b2g-v1.3T affected)

Details

(Whiteboard: [perf-reviewed] [tarako-exploratory])

Attachments

(2 attachments)

Posted file Firewatch Log
User plays song within Music App and has a second device attempt calling the test device. When the call is recognized on the test device, for example at the 25 second mark of the music track, and the user terminates the call without answering it, Music App resumes 2-3 seconds after the time it paused.

Prerequisites:
1. Have at least one song saved within Music App

Repro Steps: 
1) Update a Tarako to BuildID: 20140606014002
2) Tap Music App and play a song 
3) While song is playing, make call to test device from a second device
4) When test device shows incoming call animation, press cancel call button
5) Observe device behavior

Actual: 
Moment that music paused and moment music resumes is 2-3 seconds apart.

Expected: 
Music resumes at point music paused.

Notes: 
Repro frequency: (10/10, 100%) 

See attached: logcat, firewatch

Environmental Variables:
Device: Tarako 1.3T
Build ID: 20140606014002
Gaia: 33025a8b1e458ef48cb8b7fb81bdaba28c86b183
Gecko: 161d4b0448c6
Version: 28.1 (1.3T) 
Firmware Version: SP6821a-Gonk-4.0-5-12
User Agent: Mozilla/5.0 (Mobile; rv:28.1) Gecko/28.1 Firefox/28.1
This issue does not reproduce on Buri 1.3 following STR from Comment 0. When user presses the cancel button, the music resumes at the same mark the music previously paused. 

Environmental Variables:
Device: Buri 1.3
Build ID: 20140605024002
Gaia: 2408c2238254776b0d3716753b7bf917883c9915
Gecko: 6214d9d288e3
Version: 28.0 (1.3) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
Whiteboard: [tarako-exploratory] → [perf-reviewed] [tarako-exploratory]
Closing this, since it's Tarako-only. Feel free to reopen if you think it's still important.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.