Closed Bug 1022096 Opened 6 years ago Closed 6 years ago

[Messages] sms text truncated in delete messages mode

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: echang, Assigned: julienw)

References

Details

(Keywords: regression, Whiteboard: [2.0-FL-bug-bash][not-part-of-initial-sprint])

User Story

Build Information

Device: 
Gaia      
Gecko     
BuildID   
Version   
ro.build.version.incremental=
ro.build.date=

Description

Steps to Reproduce

Expected Results

Actual Results

Other Notes

Reproduction Frequency:

Attachments

(2 files)

Attached image Delete Messages.png
### Build Information
Device: Flame
Gaia      908f94fda04462001ece86e6b6c15ad8b05f7526
Gecko     https://hg.mozilla.org/mozilla-central/rev/5e8e9d864a4d
BuildID   20140605160202
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

### STR
1. Prepare an sms longer than a line
2. Open Messages -> Option -> Delete Messages
3. Characters cut off in the middle.. 
 
### Reproduction Frequency: 
100%
See Also: → 1022118
QA wanted: does it reproduce on v1.4 or v1.3?

(see attachment 8436293 [details])
Keywords: qawanted
The issue DOES reproduce on the 1.4 Flame.

The issue does NOT reproduce on the 1.3 Buri.

1.4 Environmental Variables:
Device: Flame 1.4
Build ID: 20140609000201
Gaia: 8b239e41bbd85aa7b6a2c5d388e775ba7de6fb2b
Gecko: e3f85877db29
Version: 30.0 (1.4)
Firmware Version: v10G-2

1.3 Environmental Variables:
Device: Buri 1.3
Build ID: 20140607024002
Gaia: e049de79ff46fcab51f29a88d5869c5efb48fc3c
Gecko: 90e7f697961a
Version: 28.0 (1.3) MOZ
Firmware Version: v1.2device.cfg
Keywords: qawanted
QA Contact: bmorgan
What about 1.3 Flame?
Keywords: qawanted
This issue does NOT occur on the Flame 1.3 Base Image:

Environmental Variables:
Device: Flame 1.3
Build ID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3) 
Firmware Version: v10G-2
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: bmorgan → ychung
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Joshua - The triage marking here looks incorrect. The tester here did not mark the bug with the regression & regressionwindow-wanted keyword. If the bug reproduces on 1.4, but doesn't reproduce on 1.3, then it's a regression.
Flags: needinfo?(jmitchell)
Right you are, sorry about that!
Flags: needinfo?(jmitchell)
Minor regression.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
The regression would likely point one of the visual refresh bugs anyway, so it would not be really useful.
blocking-b2g: --- → 2.0?
blocking-b2g: 2.0? → 2.0+
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage+]
QA: can we test the same STR on other apps that use the same "edit mode" panel? (eg: Contacts with a contact that has a long name, or maybe email)

Removing regressionwindow-wanted because it won't give us anything useful (will likely point to the edit mode visual refresh).
Keywords: regression
Assignee: nobody → felash
Attached file github PR
Hey Oleg,

do you have time to review this simple patch?

It used to work by chance in v1.4 because the text was (incorrectly) not displayed on the right of the panel.
Attachment #8440796 - Flags: review?(azasypkin)
Comment on attachment 8440796 [details] [review]
github PR

(In reply to Julien Wajsberg [:julienw] from comment #10)
> Created attachment 8440796 [details] [review]
> github PR
> 
> Hey Oleg,
> 
> do you have time to review this simple patch?
> 
> It used to work by chance in v1.4 because the text was (incorrectly) not
> displayed on the right of the panel.

Sure! Looks fine to me. Left small question at github.
Attachment #8440796 - Flags: review?(azasypkin) → review+
master: 68c0d6a6bc95206f179dab5b26d1a615927006c3
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S4 (20june)
Issue has been marked resolved - removing QA-Wanted keywords
Keywords: qawanted
Blocks: sms-sprint-3
Whiteboard: [2.0-FL-bug-bash] → [2.0-FL-bug-bash][not-part-of-initial-sprint]
Works okay with these 2 builds.
Flame Aurora v2.0
Gaia      1dd043857399c713e3b509c0ed31bdf20326f08b
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/3f9d7a3a0b7b
BuildID   20140707160206
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

Flame Master v2.1
Gaia      e935f4ff190b76c70d9b2af8856c542a6e4a7546
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/3f9d7a3a0b7b
BuildID   20140707160206
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.