Pasted URL gets autocompleted instantly (paste+enter takes you to the wrong page)

RESOLVED DUPLICATE of bug 776408

Status

()

RESOLVED DUPLICATE of bug 776408
4 years ago
3 years ago

People

(Reporter: ws.bugzilla, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Steps:

- Make sure that https://en.wikipedia.org/wiki/Rain is not in your autocompletion history
- Navigate to https://en.wikipedia.org/wiki/Rain_%28disambiguation%29
- Close tab
- Open new, blank tab
- Paste https://en.wikipedia.org/wiki/Rain
- Press Enter

Expected: you go to https://en.wikipedia.org/wiki/Rain

Actual: you go to https://en.wikipedia.org/wiki/Rain_%28disambiguation%29

This bug has been fixed earlier as bug 717772, but is back again. I personally think a delay (used in bug 717772) is the wrong way to fix this; there really should not be any inline autocompletion when I paste an entire URL, fully replacing the old one.
Stumbled across this talking to glind.  I agree with the bug filed, we should have no delay in showing results, but we should only do inline autocomplete on text entry.  cc-ing relevant folks.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 776408
You need to log in before you can comment on or make changes to this bug.