Assertion failure: JS_IsNeuteredArrayBufferObject(obj), at dom/workers/XMLHttpRequest.cpp:1191

RESOLVED DUPLICATE of bug 1022607

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 1022607
4 years ago
4 years ago

People

(Reporter: dougc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Hit this assertion while trying to install an application from the market on Firefox for Android.

Comment 1

4 years ago
Thanks for this information.

I don't have Android debug environment at hand.  It's not reproducible on B2G flame device, will see if there are other ways to reproduce it, as the issue occurs in generic code path.
(Reporter)

Comment 2

4 years ago
Here's a backtrace in case it helps:

#0  0x7ee46278 in (anonymous namespace)::EventRunnable::PreDispatch (this=0x8a6766c0, aCx=0x84710100, aWorkerPrivate=0x7718c140) at dom/workers/XMLHttpRequest.cpp:1191
#1  0x7ee3dbd8 in mozilla::dom::workers::WorkerRunnable::Dispatch (this=0x8a6766c0, aCx=0x84710100) at dom/workers/WorkerRunnable.cpp:104
#2  0x7ee444e8 in mozilla::dom::workers::Proxy::HandleEvent (this=0x8a1c3cf0, aEvent=<optimized out>) at dom/workers/XMLHttpRequest.cpp:1075
#3  0x7ed09ec4 in mozilla::EventListenerManager::HandleEventSubType (this=this@entry=0x8a2d9b80, aListener=<optimized out>, aListener@entry=0x8a198d78, aDOMEvent=0x8a1e7bc0, aCurrentTarget=0x7718c2c4, 
    aCurrentTarget@entry=0x84ddfbe0) at dom/events/EventListenerManager.cpp:936
#4  0x7ed0a198 in mozilla::EventListenerManager::HandleEventInternal (this=0x8a2d9b80, aPresContext=<optimized out>, aEvent=0x8a21ee70, aDOMEvent=aDOMEvent@entry=0x7718c3e8, aCurrentTarget=<optimized out>, 
    aCurrentTarget@entry=0x84ddfbe0, aEventStatus=<optimized out>, aEventStatus@entry=0x7718c3ec) at dom/events/EventListenerManager.cpp:997
#5  0x7ed10508 in HandleEvent (aEventStatus=0x7718c3ec, aCurrentTarget=0x84ddfbe0, aDOMEvent=0x7718c3e8, aEvent=<optimized out>, aPresContext=<optimized out>, this=<optimized out>)
    at ../../dist/include/mozilla/EventListenerManager.h:328
#6  mozilla::EventTargetChainItem::HandleEvent (this=<optimized out>, aVisitor=..., aCd=...) at dom/events/EventDispatcher.cpp:198
#7  0x7ed0a4b4 in mozilla::EventTargetChainItem::HandleEventTargetChain (aChain=..., aVisitor=..., aCallback=0x0, 
    aCallback@entry=0x7ed0b1fc <mozilla::EventDispatcher::DispatchDOMEvent(nsISupports*, mozilla::WidgetEvent*, nsIDOMEvent*, nsPresContext*, nsEventStatus*)+264>, aCd=...)
    at dom/events/EventDispatcher.cpp:288
#8  0x7ed0ad90 in mozilla::EventDispatcher::Dispatch (aTarget=<optimized out>, aPresContext=<optimized out>, aEvent=0x8a21ee70, aDOMEvent=aDOMEvent@entry=0x8a1e7bc0, aEventStatus=0x0, aCallback=0x0, 
    aTargets=0x0) at dom/events/EventDispatcher.cpp:601
#9  0x7ed0b1fc in mozilla::EventDispatcher::DispatchDOMEvent (aTarget=0x84ddfbe0, aEvent=<optimized out>, aDOMEvent=0x8a1e7bc0, aPresContext=0x0, aEventStatus=0x0)
    at dom/events/EventDispatcher.cpp:668
#10 0x7f007120 in nsXMLHttpRequest::DispatchProgressEvent (this=this@entry=0x84ddfbe0, aTarget=aTarget@entry=0x84ddfbe0, aType=..., aLengthComputable=<optimized out>, aLoaded=28761, aTotal=0)
    at content/base/src/nsXMLHttpRequest.cpp:1479
#11 0x7f00c1f4 in nsXMLHttpRequest::MaybeDispatchProgressEvents (this=0x84ddfbe0, aFinalProgress=<optimized out>) at content/base/src/nsXMLHttpRequest.cpp:3563
#12 0x7f01345c in nsXMLHttpRequest::OnDataAvailable (this=0x84ddfbe0, request=<optimized out>, ctxt=<optimized out>, inStr=<optimized out>, sourceOffset=8452, count=20309)
    at content/base/src/nsXMLHttpRequest.cpp:1901
#13 0x7ddfaa44 in nsStreamListenerWrapper::OnDataAvailable (this=<optimized out>, aRequest=0x8934f034, aContext=0x0, aInputStream=0x8a214400, aOffset=8452, aCount=20309)
    at ../../../dist/include/nsStreamListenerWrapper.h:28
#14 0x7ddf5038 in nsStreamListenerTee::OnDataAvailable (this=<optimized out>, request=0x8934f034, context=0x0, input=<optimized out>, offset=8452, count=20309)
    at netwerk/base/src/nsStreamListenerTee.cpp:93
#15 0x7def8240 in mozilla::net::nsHttpChannel::OnDataAvailable (this=0x8934f000, request=<optimized out>, ctxt=<optimized out>, input=0x8a1efca0, offset=8452, count=20309)
    at netwerk/protocol/http/nsHttpChannel.cpp:5325
#16 0x7ddd6660 in nsInputStreamPump::OnStateTransfer (this=this@entry=0x8a6621d0) at netwerk/base/src/nsInputStreamPump.cpp:599
#17 0x7ddd9d88 in nsInputStreamPump::OnInputStreamReady (this=0x8a6621d0, stream=<optimized out>) at netwerk/base/src/nsInputStreamPump.cpp:436
#18 0x7dd41a94 in nsInputStreamReadyEvent::Run (this=0x8939fc00) at xpcom/io/nsStreamUtils.cpp:88
#19 0x7dd54084 in nsThread::ProcessNextEvent (this=0x75642500, aMayWait=<optimized out>, aResult=0x7718c7d7) at xpcom/threads/nsThread.cpp:766
#20 0x7dcdcf7c in NS_ProcessNextEvent (thread=0x75642500, mayWait=<optimized out>) at xpcom/glue/nsThreadUtils.cpp:263
#21 0x7e0371d4 in mozilla::ipc::MessagePump::Run (this=0x75601d60, aDelegate=0x756530c0) at ipc/glue/MessagePump.cpp:95
#22 0x7e00c9e8 in MessageLoop::RunInternal (this=this@entry=0x756530c0) at ipc/chromium/src/base/message_loop.cc:229
#23 0x7e00ca14 in RunHandler (this=0x756530c0) at ipc/chromium/src/base/message_loop.cc:222
#24 MessageLoop::Run (this=0x756530c0) at ipc/chromium/src/base/message_loop.cc:196
#25 0x7eae3f18 in nsBaseAppShell::Run (this=0x75629d40) at widget/xpwidgets/nsBaseAppShell.cpp:164
#26 0x7f93f4c0 in nsAppStartup::Run (this=0x84d625e0) at toolkit/components/startup/nsAppStartup.cpp:278
#27 0x7f8c3f68 in XREMain::XRE_mainRun (this=this@entry=0x7718c98c) at toolkit/xre/nsAppRunner.cpp:4012
#28 0x7f8c4378 in XREMain::XRE_main (this=this@entry=0x7718c98c, argc=argc@entry=10, argv=argv@entry=0x75630148, aAppData=aAppData@entry=0x75408be0 <sAppData>)
    at toolkit/xre/nsAppRunner.cpp:4083
#29 0x7f8c45a4 in XRE_main (argc=10, argv=0x75630148, aAppData=0x75408be0 <sAppData>, aFlags=<optimized out>) at toolkit/xre/nsAppRunner.cpp:4297
#30 0x7f8cc1f0 in GeckoStart (data=data@entry=0x7563c2c0, appData=0x75408be0 <sAppData>) at toolkit/xre/nsAndroidStartup.cpp:73
#31 0x753ca8bc in Java_org_mozilla_gecko_mozglue_GeckoLoader_nativeRun (jenv=0x76a9aaa8, jc=<optimized out>, jargs=0x22900005) at mozglue/android/APKOpen.cpp:379

Comment 3

4 years ago
There is another bug 1022607 which should be same as this one.
I've submitted a patch there as below, could you try if it works for you?
https://bugzilla.mozilla.org/attachment.cgi?id=8437562

Comment 4

4 years ago
The same assertion failure can be reproduced by the test case of bug 1022607 in debug version, it's quite possible to be the same issue, so mark it as such.  Now the fix has been landed, please reopen it if you still encounter it latest mozilla central.  Thank you for being the first one to report such issue! :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1022607
You need to log in before you can comment on or make changes to this bug.