Closed Bug 1022480 Opened 10 years ago Closed 10 years ago

permission-request screen has a bonus message about "Select a camera" (but with no ability to do so, or reason for doing so)

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: dholbert, Assigned: gasolin)

References

Details

(Keywords: regression, Whiteboard: ft:loop, [FT:System-Platform][p=1])

Attachments

(5 files)

Attached image screenshot
STR:
 1. Launch any app that requires geolocation. (for the first time, so that you get a prompt).  E.g. "Here Maps", or camera, or the "Geoloc" testing app

 2. Look at the bottom of the permission prompt.

ACTUAL RESULTS: Below the information about the geolocation permission request, there's an additional message that says:
> Select a camera for Geoloc
(or whatever the app's name is -- in my case, I'm using Geoloc)

EXPECTED RESULTS: No message about a camera (since this is purely a geolocation prompt).

I've hit this with the e.me search bar, the "camera" app, Here maps, and the "Geoloc" test app, all today.



Device/Version info:
I'm using a Flame device, running a locally-built version of B2G trunk.
OS Version: 2.0.0.0-prerelease
Git commit info: 2014-06-08 87a937c5

Adding 'regression' keyword, since I can't reproduce this in older Gaia versions. (e.g. I can't reproduce using whatever gaia version comes with the Simulator version of Firefox OS 2.0 -- it looks like that's using a pre-visual-refresh version of Gaia, or something.
Summary: Geolocation permission-request screen has a bonus message about "Select a camera" → Geolocation permission-request screen has a bonus message about "Select a camera" (but with no ability to do so, or reason for doing so)
Saw this as well. I think this is likely a regression from bug 938467.

Noming because is irrelevant UX showing up on a prompt that shows up all over the OS.

Fred - Can you take a look?
Blocks: 938467
blocking-b2g: --- → 2.0?
Flags: needinfo?(gasolin)
blocking-b2g: 2.0? → 2.0+
looks like a regression to pass TBPL.
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
Flags: needinfo?(gasolin)
See Also: → 1021876
Search results also has this weird message.
In origin patch I reverted the global .hidden style to prevent pollute other system styles but missed to add this specific .hidden style.
Attachment #8436816 - Flags: review?(alive)
It's not only occurred in geolocation, but all permission dialogs
Summary: Geolocation permission-request screen has a bonus message about "Select a camera" (but with no ability to do so, or reason for doing so) → permission-request screen has a bonus message about "Select a camera" (but with no ability to do so, or reason for doing so)
See Also: 1021876
Whiteboard: ft:loop
Patch looks good! Thanks guys! 
(Designer for Camera)
Not sure ft:loop means since Fred of my team is working on this.

Changing component because this is a permission dialog bug.
Component: Gaia::System::Window Mgmt → Gaia::System
Whiteboard: ft:loop → ft:loop, [FT:System-Platform]
Attachment #8436816 - Flags: review?(alive) → review+
merged https://github.com/mozilla-b2g/gaia/commit/27089faa5fbe8dea6768f5d45187a2f5b4ce9bc5

thanks!
Whiteboard: ft:loop, [FT:System-Platform] → ft:loop, [FT:System-Platform][p=1]
Target Milestone: --- → 2.0 S4 (20june)
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
This issue has been verified successfully on Flame 2.0 & 2.1.
See attachment: Verify_1022480_flame_1.png & Verify_1022480_flame_2.png
Reproducing rate: 0/10

Flame v2.0 version:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141201000201
Version         32.0

Flame v2.1 version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: