Searching for the term "dictionary" turns up some valid search results that cannot be clicked due to missing icons

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Search
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jsmith, Assigned: lightsofapollo)

Tracking

unspecified
2.0 S4 (20june)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Build

* Device: Flame
* Version: 2.0 - b2g-inbound
* Build ID: 20140608173002
* Gaia: 12af93123c5db55212d51fe235d39f21209a1eaa
* Gecko: 7f3f35b511f8

STR

1. Open rocketbar search
2. Search for dictionary
3. Try to click the search results that have no icons

Expected

Clicking a search result with no icon should launch the relevant e.me app.

Actual

Clicking a search result with no icon does nothing.

Additional Notes

This reproduces with other search terms that return search results with no icons. I saw this also happen when I searched for the word face.

We probably should have default fallback icons for e.me apps with no icon.
(Reporter)

Updated

4 years ago
Blocks: 989848
blocking-b2g: --- → 2.0?
Whiteboard: [systemsfe]
(Reporter)

Comment 1

4 years ago
Created attachment 8436682 [details]
Screenshot
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1022975
(Assignee)

Comment 3

4 years ago
This is in my midsized icon rollup patch which deals with showing default images on network errors.
Assignee: nobody → jlal
(Assignee)

Updated

4 years ago
Depends on: 1022247
(Reporter)

Updated

4 years ago
Blocks: 1015336
No longer blocks: 989848
QA Whiteboard: [VH-FC-blocking+]
(Assignee)

Comment 4

4 years ago
Should be fixed by https://github.com/mozilla-b2g/gaia/commit/5438f4773400a77f4d04f9e120a3c488c699ef7b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → fixed
Uplifted in another bug.
status-b2g-v2.0: affected → fixed
No more missing icons on dictionary results.
Status: RESOLVED → VERIFIED
I saw some issue with the Marketplace installing a dictionary.  Need to investigate.

STR works verified 2.0:
Gaia      23e06c3624309db22ad9cb736d89700768b42b36
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/164b61458ca5
BuildID   20140619000200
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
flame
status-b2g-v2.0: fixed → verified
Fixed in bug 1022247.
status-b2g-v2.0: verified → fixed
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
Target Milestone: --- → 2.0 S4 (20june)
You need to log in before you can comment on or make changes to this bug.