Build error in --disable-webrtc builds: "MediaManager.cpp:54:39: fatal error: browser_logging/WebRtcLog.h: No such file or directory"

RESOLVED FIXED in Firefox 32

Status

()

Core
WebRTC
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dholbert, Assigned: dholbert)

Tracking

Trunk
mozilla33
x86_64
Linux
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox32 fixed, firefox33 fixed)

Details

Attachments

(1 attachment)

Build error, with up-to-date mozilla-central this morning, in a --disable-webrtc build:
{
dom/media/MediaManager.cpp:54:39: fatal error: browser_logging/WebRtcLog.h: No such file or directory
#include "browser_logging/WebRtcLog.h"
^
}
Created attachment 8437036 [details] [diff] [review]
fix v1: Add #ifdef wrappers

This seems to fix things.
Attachment #8437036 - Flags: a11y-review?(rjesup)
Attachment #8437036 - Flags: a11y-review?(rjesup) → review?(rjesup)

Updated

4 years ago
Attachment #8437036 - Flags: review?(rjesup) → review+
https://hg.mozilla.org/mozilla-central/rev/2f90c888b85b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Comment on attachment 8437036 [details] [diff] [review]
fix v1: Add #ifdef wrappers

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 970713 

User impact if declined: Unable to build Aurora (and then Beta, and then Release) with --disable-webrtc

Testing completed (on m-c, etc.): on m-c

Risk to taking this patch (and alternatives if risky): Minimal. This has zero effect on official builds -- just adding an #ifdef for a symbol that's known-to-be-defined in official builds. (so maybe arguably NPOTB, but I'm requesting approval to be on the safe side.

String or IDL/UUID changes made by this patch: none
Attachment #8437036 - Flags: approval-mozilla-aurora?
Comment on attachment 8437036 [details] [diff] [review]
fix v1: Add #ifdef wrappers

Aurora approval granted.
Attachment #8437036 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/f9b60c46c1ed
Assignee: nobody → dholbert
status-firefox32: --- → fixed
status-firefox33: --- → fixed
You need to log in before you can comment on or make changes to this bug.