Closed Bug 1022908 Opened 10 years ago Closed 10 years ago

[B2G][Flame][Browser] Camera and microphone permissions are truncated

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: rpribble, Assigned: gasolin)

References

Details

(Whiteboard: [2.0-flame-test-run-1]ft:loop)

Attachments

(4 files)

Attached image Screenshot.png
Description:
The permissions page for sharing the camera and microphone in the browser is truncated. 

Repro Steps:
1) Update a Flame to BuildID: 20140609040203
2) Launch the browser
3) Navigate to http://apprtc.appspot.com/
4) Observe permissions page when it pops up

Actual:
The permissions page for sharing the camera and microphone in the browser appears to be truncated.

Expected:
All content fits within the page.

v2.0 Environmental Variables:
Device: Flame v2.0 MOZ ril
BuildID: 20140609040203
Gaia: 12af93123c5db55212d51fe235d39f21209a1eaa
Gecko: 9305a8ec77fe
Version: 32.0a1
Firmware Version: v10G-2


Notes:


Repro frequency: 100%
See attached: Screenshot, logcat
Component: Gaia::Browser → Gaia::System::Window Mgmt
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1]ft:loop
Qawanted for results on Buri 2.0.
Keywords: qawanted
@omega any suggestion to improve this?
Flags: needinfo?(ofeng)
(In reply to Rachel Pribble from comment #1)
> Qawanted for results on Buri 2.0.

Don't worry about checking this - it's not a critical bug, but something we could look into fixing.
Keywords: qawanted
Let's just wrap the message. For this case, it will look like:
	Would you like to
	share your camera
	and microphone with
	https://apprtc.appsp
	ot.com?

Jenny, do you have any comment?
Flags: needinfo?(ofeng) → needinfo?(jelee)
Thumbs up!
Flags: needinfo?(jelee)
Whiteboard: [2.0-flame-test-run-1]ft:loop → [2.0-flame-test-run-1]ft:loop [good-first-bug] [mentor=gasolin][lang=zh-tw]
Attached image ui.png
on inari, with set `word-wrap: break-word` in #permission-message, the UI will be 

```
would you like to
share your camera
with
http://mozilla.github.io
```
Assignee: nobody → gasolin
Whiteboard: [2.0-flame-test-run-1]ft:loop [good-first-bug] [mentor=gasolin][lang=zh-tw] → [2.0-flame-test-run-1]ft:loop
Attachment #8439662 - Flags: review?(alive)
Attachment #8439662 - Flags: review?(alive) → review+
Comment on attachment 8439662 [details] [review]
pull request redirect to github

merged to gaia-master https://github.com/mozilla-b2g/gaia/commit/ac29c196e8f3ae21d6da736b996a28460cbc2b0a

thanks!


[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): feature bug 938467
[User impact] if declined: The small device (inari-like) will show truncated url
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): css only change, none
[String changes made]:
Attachment #8439662 - Flags: approval-gaia-v2.0?
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Attachment #8439662 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
This issue has been verified successfully on Flame 2.0 & 2.1.
See attachment: Verify_1022908_Flame.png
Reproducing rate: 0/10

Flame v2.0 version:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141130000204
Version         32.0

Flame v2.1 version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141130001203
Version         34.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: