Closed Bug 1022976 Opened 6 years ago Closed 6 years ago

[Collection] Intermittent adding records does not work

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

(Whiteboard: [p=2],[systemsfe])

Attachments

(2 files)

We have noticed that occasionally adding new datastore records does not work. I am still working on getting a reduced test case for this.

One place where you can frequently see this is adding multiple collections in the vertical homescreen. If you long tap on the homescreen and tap several collections, not all of them will be added. We are also seeing new bookmarks occasionally not show up.
Andrea - Just doing a ni? on you so you are aware, and maybe could point me to a dupe bug if one exists. I wonder if this could be from the recent rewrite?
Flags: needinfo?(amarchesini)
(In reply to Kevin Grandon :kgrandon from comment #1)
> Andrea - Just doing a ni? on you so you are aware, and maybe could point me
> to a dupe bug if one exists

Not really. I don't think it's related to the rewriting of the service. but definitely it seems a bug. Tell me more about how I can reproduce the issue. Thanks!
Flags: needinfo?(amarchesini)
Andrea - here's a more solid STR. Do you have the vertical homescreeen installed? Here is a brief STR, I can work on getting you a more reduced test case, but I think that would take quite  abit of time.

1 - On a device with the vertical homescreen, scroll to the bottom of the homescreen.

2 - If an empty area does not exist, drag an icon over the last divider to create one. Exit edit mode if needed.

3 - Long tap on an empty space on the homescreen, eventually a list of categories should appear.

4 - Select several categories (3-4), and press ok.

Expected result:
Several items should be added to the homescreen, one for each selected category in step 4.

Actual result:
Sometimes only 1 or 2 items will be added.
Flags: needinfo?(amarchesini)
QA Whiteboard: [VH-FC-blocking+]
Marked as 2.0? blocker as adding multiple Smart Collections at once was a use case in 1.4.
blocking-b2g: --- → 2.0?
Turns out this is not related to datastore, yaay! We are passing in the same ID for things sometimes because we default the id to be a date, that was silly. Taking.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Component: DOM: Device Interfaces → Gaia
Flags: needinfo?(amarchesini)
Product: Core → Firefox OS
Summary: [Datastore] Intermittent adding records does not work → [Collection] Intermittent adding records does not work
Whiteboard: [p=2],[systemsfe]
Removing you Andrea - thanks for taking the time, and sorry about the confusion.
Attached file Github pull request
Hey - either of you guys have time to review this one? Added a little unit test to ensure we don't regress it, though I'd love to do an integration test in the future.
Attachment #8439354 - Flags: review?(ran)
Attachment #8439354 - Flags: review?(amirn)
Component: Gaia → Gaia::Homescreen
Duplicate of this bug: 1024336
Comment on attachment 8439354 [details] [review]
Github pull request

did not test the calendar app, but the collections part looks good.
Attachment #8439354 - Flags: review?(ran)
Attachment #8439354 - Flags: review?(amirn)
Attachment #8439354 - Flags: review+
QA Whiteboard: [VH-FC-blocking+] → [VH-FL-blocking-][VH-FC-blocking+]
Landed: https://github.com/mozilla-b2g/gaia/commit/d0fc0505d4257b80a49acd8ffa7155d6c7023632
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: 2.0? → 2.0+
Verified by adding the whole 14 standard Smart Collection, no one is missing in Homescreen.
Status: RESOLVED → VERIFIED
Attached video Verify_Video_Flame.MP4
This issue has been verified successfully on Flame 2.0 &2.1.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/10

Flame v2.0 version:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141130000204
Version         32.0

Flame v2.1 version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141130001203
Version         34.0
You need to log in before you can comment on or make changes to this bug.