Closed Bug 1023001 Opened 5 years ago Closed 5 years ago

Gaia unit test perma-hanging ("timed out after 1760 seconds of no output") on Trunk

Categories

(Firefox OS Graveyard :: Gaia, defect, blocker)

x86_64
Linux
defect
Not set
blocker

Tracking

(firefox31 unaffected, firefox32 unaffected, firefox33 fixed, firefox-esr24 unaffected, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S4 (20june)
Tracking Status
firefox31 --- unaffected
firefox32 --- unaffected
firefox33 --- fixed
firefox-esr24 --- unaffected
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: RyanVM, Assigned: jgriffin)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

It appears to have started with the version bump on m-c, but the timing could also be pointing to something in today's reconfig. I have retriggers going on earlier pushes to hopefully help narrow it down. Tests are passing fine on Aurora32. Trunk trees are currently closed.

https://tbpl.mozilla.org/php/getParsedLog.php?id=41392923&tree=Mozilla-Central

b2g_ubuntu64_vm mozilla-central opt test gaia-unit on 2014-06-09 15:51:27 PDT for push 4bf5e8d7c440
slave: tst-linux64-spot-876

16:00:52     INFO -  starting WebSocket Server
16:00:52     INFO -  Xlib:  extension "RANDR" missing on display ":0".
16:00:53     INFO -  1402354853374	Marionette	INFO	marionette enabled via build flag and pref
16:00:53     INFO -  1402354853606	Marionette	INFO	marionette-server.js loaded
16:00:53     INFO -  1402354853651	Marionette	INFO	Listening on port 2828
16:00:53     INFO -  1402354853652	Marionette	INFO	Marionette server ready
16:00:53     INFO -  System JS : WARNING resource://gre/modules/Preferences.jsm:36 - mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create
16:00:53     INFO -  Identity SignInToWebsiteController: persona uri = https://firefoxos.persona.org
16:00:57     INFO -  ###################################### forms.js loaded
16:00:57     INFO -  ############################### browserElementPanning.js loaded
16:00:57     INFO -  ######################## BrowserElementChildPreload.js loaded
16:00:57     INFO -  *** UTM:SVC TimerManager:registerTimer - id: user-agent-updates-timer
16:00:57     INFO -  ############ ErrorPage.js
16:00:58     INFO -  Xlib:  extension "RANDR" missing on display ":0".
16:00:58     INFO -  ###################################### forms.js loaded
16:00:58     INFO -  ############################### browserElementPanning.js loaded
16:00:58     INFO -  ######################## BrowserElementChildPreload.js loaded
16:02:53     INFO -  *** UTM:SVC TimerManager:notify - notified @mozilla.org/b2g/webapps-update-timer;1
16:04:53     INFO -  *** UTM:SVC TimerManager:notify - notified @mozilla.org/addons/integration;1
16:06:53     INFO -  *** UTM:SVC TimerManager:notify - notified @mozilla.org/extensions/blocklist;1
16:08:53     INFO -  *** UTM:SVC TimerManager:notify - notified timerID: user-agent-updates-timer
16:08:53     INFO -  *** UTM:SVC TimerManager:registerTimer - id: user-agent-updates-timer
16:38:14     INFO - Automation Error: mozprocess timed out after 1760 seconds running ['/builds/slave/test/build/venv/bin/python', '-u', '/builds/slave/test/gaia/tests/python/gaia-unit-tests/gaia_unit_test/main.py', '--binary', '/builds/slave/test/build/application/b2g/b2g-bin', '--profile', '/builds/slave/test/gaia/profile-debug', '--symbols-path', 'https://ftp-ssl.mozilla.org/pub/mozilla.org/b2g/tinderbox-builds/mozilla-central-linux64_gecko/1402323097/en-US/b2g-33.0a1.en-US.linux-x86_64.crashreporter-symbols.zip']
16:38:14    ERROR - timed out after 1760 seconds of no output
16:38:14    ERROR - Return code: -9
16:38:14     INFO - TinderboxPrint: gaia-unit-tests: <em class="testfail">T-FAIL</em>
16:38:14    ERROR - Tests exited with return code -9: harness failures
16:38:14    ERROR - # TBPL FAILURE #
The problem is that --runapp is broken; the build isn't even launching the TestAgent app.
Moving to General since this isn't a TestAgent issue.
Component: Gaia::TestAgent → General
I retriggered a Gaia unit test job on a previously-green run and it was also green. Right now, the only common theme I can find among when the failures started is the version bump.
Usually if I got this sort of issue in Thunderbird I would be looking at min/max versions for test extensions - is there something similar for Test Agent?  I have no idea where that code is.
(In reply to Mark Banner (:standard8) from comment #5)
> Usually if I got this sort of issue in Thunderbird I would be looking at
> min/max versions for test extensions - is there something similar for Test
> Agent?  I have no idea where that code is.

Bingo, Mark wins the prize.  

There are several extensions which are used in the debug profile at https://github.com/mozilla-b2g/gaia/tree/master/tools/extensions; several of them contain maxVersion 32.0, so the recent version bump broke them.
For posterity, this was a regression from bug 861424.
Depends on: 861424
And we're green again. Will merge b2g-inbound around and re-open the trees shortly.
Assignee: nobody → jgriffin
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S4 (20june)
More like generic Gaia issue since there isn't a specific component for DEBUG=1 add-ons.
Component: General → Gaia
Ryan, does it make sense to land this on the various still worked-on branches? At least v2.0 (if it was after the merge), v1.4, v1.3t.

(I think it's useful, I usually use the same Firefox to run my local tests even if Travis should use the correct one..)
Flags: needinfo?(ryanvm)
Seems unlikely that we're ever going to bump the Gecko rev past 32 on those branches, so what would it accomplish?
Flags: needinfo?(ryanvm)
But honestly, I have no opinion.
If you're going to use older branches with the latest Firefox, then yes, it makes sense to merge these to older branches.
Yes, that's what I meant: I usually use the same nightly to run the test agent on the branches. Moreover, since we moved the test-agent files, I have to regenerate a profile when I switch to v1.3t (not sure about v1.4), so the "bad" httpd would definitely be in the profile.

Ryan, can you do the uplift then?
Flags: needinfo?(ryanvm)
You need to log in before you can comment on or make changes to this bug.