xpcom/string/src/nsUTF8UtilsSSE2.cpp: error: #error "SSE2 instruction set not enabled"

RESOLVED FIXED in Firefox 31

Status

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: jbeich, Assigned: jbeich)

Tracking

Trunk
mozilla33
x86
FreeBSD
Dependency tree / graph

Firefox Tracking Flags

(firefox31 fixed, firefox32 fixed, firefox33 fixed)

Details

Attachments

(1 attachment)

Bug 979118 replaced GNU_CC ifdefs with OS-specific SSE2_FLAGS. As not every platform is special-cased in configure.in absence of -msse2 leads to an error later in the build. At least DragonFly, FreeBSD and GNU/kFreeBSD are affected.

In file included from xpcom/string/src/nsUTF8UtilsSSE2.cpp:7:0:
/usr/local/lib/gcc48/gcc/i386-portbld-freebsd9.1/4.8.4/include/emmintrin.h:31:3: error: #error "SSE2 instruction set not enabled"
 # error "SSE2 instruction set not enabled"
   ^
xpcom/string/src/nsUTF8UtilsSSE2.cpp: In member function 'void LossyConvertEncoding16to8::write_sse2(const char16_t*, uint32_t)':
xpcom/string/src/nsUTF8UtilsSSE2.cpp:25:3: error: '__m128i' was not declared in this scope
   __m128i vectmask = _mm_set1_epi16(0x00ff);
   ^
Attachment #8437400 - Flags: review?(mh+mozilla)
Alias: :ehsan
Attachment #8437400 - Flags: review?(mh+mozilla) → review+
Can someone push to Try?

try: -b o -p all -u none -t none
Comment on attachment 8437400 [details] [diff] [review]
move under GNU_CC block

Let's backport to help downstream not carry around i386 buildfix for esr31 lifetime.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 979118
User impact if declined: broken build on dragonfly i386, freebsd i386, debian/kfreebsd i386
Testing completed (on m-c, etc.): soon
Risk to taking this patch (and alternatives if risky): Low, broken build at most.
String or IDL/UUID changes made by this patch: None
Attachment #8437400 - Flags: approval-mozilla-beta?
Attachment #8437400 - Flags: approval-mozilla-aurora?
Attachment #8437400 - Flags: approval-mozilla-beta?
Attachment #8437400 - Flags: approval-mozilla-beta+
Attachment #8437400 - Flags: approval-mozilla-aurora?
Attachment #8437400 - Flags: approval-mozilla-aurora+
Landry, can you help with Try push?
Flags: needinfo?(landry)
Why don't you ask for commit access for try?
He doesnt want to disclose his real identity....

https://tbpl.mozilla.org/?tree=Try&rev=2fa0230ffd35
Flags: needinfo?(landry)
Keywords: checkin-needed
Whiteboard: [checkin-needed-beta] [checkin-needed-aurora]
https://hg.mozilla.org/integration/mozilla-inbound/rev/bca9fe3d4cf7

Friendly reminder that your commit message should be summarizing what the patch is actually doing, not just restating the problem it's fixing. Thanks!
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Committing_Rules_and_Responsibilities#Checkin_comment
Assignee: nobody → jbeich
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/bca9fe3d4cf7
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Depends on: 1243861
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.