Closed Bug 1023200 Opened 7 years ago Closed 7 years ago

[Mulet] Calendar Views.Month unit test fails

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gerard-majax, Assigned: gerard-majax)

References

Details

Attachments

(1 file)

Running Calendar unit tests in Mulet exposes the following failure:

>  2) [calendar-test/unit/views/month_test.js] Views.Month #_onswipe:
>     Error: selects first day of month: expected undefined to equal Thu, 31 May 2012 22:00:00 GMT
>      at chaiAssert (http://calendar.gaiamobile.org:8080/common/test/helper.js:33:1)
>      at eql (http://calendar.gaiamobile.org:8080/common/vendor/chai/chai.js:530:1)
>      at deepEqual (http://calendar.gaiamobile.org:8080/common/vendor/chai/chai.js:1331:5)
>      at (anonymous) (http://calendar.gaiamobile.org:8080/test/unit/views/month_test.js:157:1)
>      at wrapper (http://calendar.gaiamobile.org:8080/common/test/mocha_generators.js:62:13)
>      at run (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3709:7)
>      at runTest (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4081:5)
>      at (anonymous) (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4127:7)
>      at next (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4007:7)
>      at (anonymous) (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4016:7)
>      at next (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3964:16)
>      at (anonymous) (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3979:7)
>      at done (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3700:5)
>      at (anonymous) (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3712:9)
>      at (anonymous) (http://calendar.gaiamobile.org:8080/common/test/mocha_generators.js:46:13)
>      at wrapper (http://calendar.gaiamobile.org:8080/common/test/mocha_generators.js:73:15)
>      at run (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3709:7)
>      at next (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3973:5)
>      at (anonymous) (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3984:5)
>      at (anonymous) (http://calendar.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4932:28)

I don't reproduce this issue with B2G only.
Blocks: 1030679
Can we get a feedback from Calendar owners?
Flags: needinfo?(mmedeiros)
Flags: needinfo?(kgrandon)
Flags: needinfo?(jlal)
Flags: needinfo?(gaye)
yes! this is broken for a long time. let's disable it. I know that running `make clean && make really-clean` sometimes solves it, but something is really wrong with this test. The code is *probably* working as expected since we are able to move to next/prev month when swiping on the calendar app.
Flags: needinfo?(mmedeiros)
Flags: needinfo?(jlal)
That sounds fine to me, do we have an integration test for this? I didn't see one when skimming the test files. If not, I would suggest disabling and creating an integration test for this, or filing a bug for a calendar dev to do so.
Flags: needinfo?(kgrandon)
Blocks: 996413
No longer blocks: 996413
+1 for integration test to replace this. Evan? Miller?
Flags: needinfo?(gaye)
It looks like it's now passing successfully.
Assignee: nobody → lissyx+mozillians
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.