[Flame][v1.4][Gaia::SMS] The contact number is shown incompletely in the contact detail screen of SMS conversion when the contact phone label is more than 19 characters.

RESOLVED FIXED in 2.1 S4 (12sep)

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: greatwall2686, Assigned: goutamnair, Mentored)

Tracking

unspecified
2.1 S4 (12sep)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: torch, [good first bug ], [lang=css], )

Attachments

(3 attachments)

Reporter

Description

5 years ago
* Description:
The contact number is shown incompletely in the contact detail screen of SMS conversion when the contact phone label is more than 19 characters.
* Precondition:
  There is a contact A which has phone label more than 19 characters in the phone book.
* Reproduction steps:
  1. Open [Message] app and create new a message.
  2. Tap on “+” icon and select contact A in the contacts list.
  3. Write the SMS text and send it.
  4. Click contact A name and check the displayed.
* Expected result:
The contact’s name, photo and phone number is shown correctly.
* Actual result: 
A part of the contact number is cover by photo box.

* Reproduction build:(Buri - Firefox OS V1.4 inside)
 - Gaia      17b102ee8d9a724b62285547cc5f1c5d30bfb01c
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/95be84248033
 - BuildID   20140520000201
 - Version   30.0

* Reproduction Frequency
  - 100%
Can we check on master please?
Keywords: qawanted
QA Contact: dgomez
This issue DOES occur on Flame 2.1

2.1 Environmental Variables:
Device: Flame 2.1
Build ID: 20140609223003
Gaia: f42ebc93554979501d3ac52bcf9e69cb4b310a4f
Gecko: 9dc0ffca10f4
Version: 33.0a1 (2.1) 
Firmware Version: v10G-2
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → QAnalyst-Triage+
Flags: needinfo?(jmitchell)
QA Whiteboard: QAnalyst-Triage+ → [QAnalyst-Triage+]
Blocks: 1015217
Status: UNCONFIRMED → NEW
Ever confirmed: true
This issue is always there, but we merely change the type manually. ni? visual to confirm that show ellipsis for the contact details is sufficient in this case(same behavior for long contact name). It should be an quick css fixing for showing ellipsis so flag a good first bug for contributor.
Flags: needinfo?(vpg)
Whiteboard: torch → torch, [good first bug ], [lang=css], [mentor=:steveck]
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(In reply to Steve Chung [:steveck] from comment #3)
> This issue is always there, but we merely change the type manually. ni?
> visual to confirm that show ellipsis for the contact details is sufficient
> in this case(same behavior for long contact name). It should be an quick css
> fixing for showing ellipsis so flag a good first bug for contributor.

I don't know if I understood this correctly, but the issue is that in Contact details there's no place to see the full contact name when it's long?
No, the contact name has an ellipsis already, the issue is for the contact detail (the phone number, or maybe in the future the email).
We can use elipsis here as well. Please set the maximum width of that line 1 rem before the image thumbnail.
Flags: needinfo?(vpg)
Mentor: schung
Whiteboard: torch, [good first bug ], [lang=css], [mentor=:steveck] → torch, [good first bug ], [lang=css],

Comment 7

5 years ago
Posted patch test.patchSplinter Review
Add an ellipsis for the details of a contact
Attachment #8444139 - Flags: review?(felash)
Comment on attachment 8444139 [details] [diff] [review]
test.patch

Review of attachment 8444139 [details] [diff] [review]:
-----------------------------------------------------------------

Hey,

this works fine for the case of the number belongs to a known contact, but not when the number is unknown. Could you please check this case?
Attachment #8444139 - Flags: review?(felash)

Comment 9

5 years ago
anyone working on this? If not, i will be happy to take it. But i would require mentoring as I am new here.
Hey dear Talhaanwar, 

Munto was working on this bug already (despite he  was not added as assignee). Munto, are you still working on this?
Flags: needinfo?(munto)

Comment 11

5 years ago
I am Talha :-). No problem Julien.

Comment 12

5 years ago
Is there anyone still working on this bug as this would be my first one if you let me do so!!!
(In reply to raj454raj from comment #12)
> Is there anyone still working on this bug as this would be my first one if
> you let me do so!!!

Since it's over 2 weeks after ni but no responds, I'll reassign to other contributor who is also interested in the issue. Hi Talha and raj454raj, please leave comment below if you could help with fixing, thanks!
Flags: needinfo?(talhaanwar.anwar)
Flags: needinfo?(raj454raj)
Assignee

Comment 14

5 years ago
Hey, i would like to work on this. Does this require a DuT?
(In reply to Goutam from comment #14)
> Hey, i would like to work on this. Does this require a DuT?

We don't have a strong deadline for this issue now, so take your time :)
Please follow this rule[1] once you finish your patch

Hi Munto, sorry that transferring the assignee to Goutam, but please let me know if you are still working on this, thanks.


[1] https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/Submitting_a_Gaia_patch
Assignee: nobody → goutamnair7
Flags: needinfo?(talhaanwar.anwar)
Flags: needinfo?(raj454raj)
Assignee

Comment 16

5 years ago
Posted file PR for Bug
Attachment #8489003 - Flags: review?(schung)
Assignee

Comment 17

5 years ago
Can you please review the PR?
Comment on attachment 8489003 [details] [review]
PR for Bug

Hi Goutam, this patch works fine, thanks for the contribution! next time please remember to leave more description on the github PR title instead of bug number only.

Sorry munto, you submit the patch at first. But next time please provide the github patch for merging to gaia master, thanks.
Attachment #8489003 - Flags: review?(schung) → review+
master: 32d82d288abe2e55146c10c066234e8ba4982836
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(munto)
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S4 (12sep)
You need to log in before you can comment on or make changes to this bug.