Closed Bug 1023303 Opened 6 years ago Closed 6 years ago

Regression: Unable to delete first character in address-bar value that has been auto-completed

Categories

(Firefox for Android :: Keyboards and IME, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 33
Tracking Status
firefox30 --- unaffected
firefox31 --- unaffected
firefox32 + verified
firefox33 --- verified
fennec 32+ ---

People

(Reporter: cos_flaviu, Assigned: jchen)

References

Details

(Keywords: regression)

Attachments

(1 file)

Environment: 
Device: Google Nexus 7 (Android 4.4.2);
Build: Nightly 33.0a1 (2014-06-10);

Steps to reproduce:
1. Launch fennec;
2. Tap on the ulr bar;
3. Start typing google.com;
4. After typing the first 2 or 3 letters tap on the 'delete' button several times to delete all the typed letters.

Expected result:
All the content from the url bar can be deleted.

Actual result:
The first letter typed in the url bar can not be deleted when autocomplete is used.

Notes:
The bug is only reproducible on android Kitkat devices.
Please check the video: http://youtu.be/iTdw74SIQL0
I couldn't reproduce this on the same device (4.4.3), same build. I assume same Google Keyboard.

See video from my attempt to reproduce the issue: https://plus.google.com/+AaronTrain/posts/5nk88c7BHnz
If anyone else can reproduce this we should track this
I am able with Nexus 4 - Android 4.4 
https://www.youtube.com/watch?v=s2Ndqkf5ci4

As seen in the video - I am able to delete it only after I change device orientation (and if I lock/unclock phone)
tracking-fennec: --- → ?
The bug is also reproducible on Google Nexus 5 (Android 4.4.3).
Let's find a regression range.
Flags: needinfo?(flaviu.cos)
Summary: Can not delete first letter in an autocomplete in the url bar → Regression: Unable to delete first character in address-bar value that has been auto-completed
Regression Window:
Last good build 2014-05-20;
First bad build 2014-05-21;
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb9f34f73ebe&tochange=9d8d16695f6a
Flags: needinfo?(flaviu.cos)
80f8cb8918bf	Jim Chen — Bug 994472 - Emulate previous backspace behavior; r=wesj
7c8ba49235f2	Jim Chen — Bug 994472 - Use text spans to implement autocompletion; r=wesj
Blocks: 994472
Component: Awesomescreen → Keyboards and IME
Flags: needinfo?(nchen)
Assignee: nobody → nchen
tracking-fennec: ? → 32+
I can reproduce on my Nexus 4.
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
I think it's really a bug in the 4.4 stock keyboard because the 4.4.2 stock keyboard doesn't have this problem. This patch works around it by forcing the IME to reset when we delete the autocompete text so that we're in sync with the IME.
Attachment #8442184 - Flags: review?(wjohnston)
Attachment #8442184 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/2b89f72bc855
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 33
Comment on attachment 8442184 [details] [diff] [review]
Restart IME when intercepting deleteSurroundingText call (v1)

Approval Request Comment

[Feature/regressing bug #]: Bug 994472

[User impact if declined]: Cannot delete character in URL bar in certain Android versions

[Describe test coverage new/current, TBPL]: Locally, m-c

[Risks and why]: Small; the fix has been tested with multiple keyboards, and it only changes the URL bar behavior in limited situations.

[String/UUID change made/needed]: None
Attachment #8442184 - Flags: approval-mozilla-aurora?
The first character in address-bar that has been auto-completed, can be deleted, so:
Verified fixed on: 
Device: LG Nexus 4 (Android 4.4.2)
Build: Firefox for Android 33.0a1 (2014-07-02)
Comment on attachment 8442184 [details] [diff] [review]
Restart IME when intercepting deleteSurroundingText call (v1)

Aurora+
Attachment #8442184 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on: 
Device: LG Nexus 4 (Android 4.4.2)
Build: Firefox for Android 32.0a2 (2014-07-06)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.